View Full Version : SPP -- ChIP-seq program installation 2??

08-20-2012, 05:39 PM
Hi guys,
I've tried install spp (http://compbio.med.harvard.edu/Supplements/ChIP-seq/) to my macbook pro or my ubuntu, met the same error. Stcuking for ages!! hope anyone can help

Here is some detailed infor:
macbook pro 10.7.4 OSX Lion
ubuntu 12.04
I've successfully installed boost C++, and R( both are the most recent one).

below is the error message I got, every time, and on both machine :

g++ -arch x86_64 -I/Library/Frameworks/R.framework/Resources/include -I/Library/Frameworks/R.framework/Resources/include/x86_64 -DNDEBUG -I/usr/local/include -I./ -D_FASTMAP -DMAQ_LONGREADS -fPIC -g -O2 -c bamread.cpp -o bamread.o
In file included from /usr/include/c++/4.2.1/backward/strstream:51,
from bamread.cpp:8:
/usr/include/c++/4.2.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
bamread.cpp:14:31: error: boost/tokenizer.hpp: No such file or directory
bamread.cpp: In function ‘SEXPREC* read_bam(SEXPREC*, SEXPREC*)’:
bamread.cpp:71: error: ‘boost’ has not been declared
bamread.cpp:71: error: expected initializer before ‘<’ token
bamread.cpp:72: error: ‘boost’ has not been declared
bamread.cpp:72: error: expected primary-expression before ‘char’
bamread.cpp:72: error: expected `;' before ‘char’
bamread.cpp:73: error: ‘boost’ has not been declared
bamread.cpp:73: error: expected primary-expression before ‘char’
bamread.cpp:73: error: expected `;' before ‘char’
make: *** [bamread.o] Error 1
ERROR: compilation failed for package ‘spp’
* removing ‘/Library/Frameworks/R.framework/Versions/2.15/Resources/library/spp’


PS. I've looked up in the forum, a relative post (http://seqanswers.com/forums/showthread.php?t=7813&highlight=spp) has similar problem, but not quite same, and the link of patch is brocken.

Many thanks.

10-03-2012, 09:21 AM
Hi Potatoo,

I am getting exactly the same error message when I tried installing spp version version 1.11 on my Mac and Linux pc. Any luck in fixing this bug?


10-05-2012, 02:31 AM
You are missing the boost library. Install the boost library and try again. Here are my notes from a while back:

# install dependencies
sudo yum update
sudo yum install gcc-c++.x86_64
sudo yum install gcc-gfortran.x86_64
sudo yum install readline-static.x86_64
sudo yum install make.x86_64
sudo yum install zlib-devel.x86_64
sudo yum install boost-devel.x86_64

# install R
wget http://cran.r-project.org/src/base/R-2/R-2.14.1.tar.gz

tar xvf R-2.14.1.tar.gz
cd R-2.14.1
# configure R with no X
sudo ./configure --with-x=no

sudo make
sudo make install

# Run R then install the following

# get spp
wget http://www.ebi.ac.uk/~anshul/public/softwareRepo/spp_package.tar.gz
tar xvf spp_package.tar.gz
cd spp_package
sudo R CMD INSTALL spp_1.10.1.tar.gz


01-06-2016, 06:20 AM

I also struggled on this issue, hope this can help (on mac OSX 10.8.5)

download latest version of spp (1.11) from http://compbio.med.harvard.edu/Supplements/ChIP-seq/

download the source for boost library and compile:

## do not forget the last step !
sudo ./b2 install

R CMD INSTALL spp_1.11.tar.gz