SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   help - buffer overflow problem of Maq in Ubuntu 8.10 (http://seqanswers.com/forums/showthread.php?t=1136)

yuanlang 02-03-2009 11:35 AM

help - buffer overflow problem of Maq in Ubuntu 8.10
 
Hi,

I compiled maq 0.7.1 by "configure;make;sudo make install" and tried to run "maq.pl demo" in my Ubuntu 8.10 desktop yesterdau. However I ran into a problem as below:

*** buffer overflow detected ***: /usr/local/bin/maq terminated
======= Backtrace: =========
/lib/libc.so.6(__fortify_fail+
0x37)[0x7fa3946b0887]
/lib/libc.so.6[0x7fa3946ae750]
/usr/local/bin/maq[0x423ebe]
/usr/local/bin/maq[0x424465]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7fa3945cf466]
/usr/local/bin/maq[0x401da9]
======= Memory map: ========
00400000-00438000 r-xp 00000000 08:05 2164005 /usr/local/bin/maq
00637000-00638000 r--p 00037000 08:05 2164005 /usr/local/bin/maq
00638000-0063b000 rw-p 00038000 08:05 2164005 /usr/local/bin/maq
0229e000-022bf000 rw-p 0229e000 00:00 0 [heap]
7fa3945b1000-7fa39471a000 r-xp 00000000 08:05 3612716 /lib/libc-2.8.90.so
7fa39471a000-7fa394919000 ---p 00169000 08:05 3612716 /lib/libc-2.8.90.so
7fa394919000-7fa39491d000 r--p 00168000 08:05 3612716 /lib/libc-2.8.90.so
7fa39491d000-7fa39491e000 rw-p 0016c000 08:05 3612716 /lib/libc-2.8.90.so
7fa39491e000-7fa394923000 rw-p 7fa39491e000 00:00 0
7fa394923000-7fa394939000 r-xp 00000000 08:05 3612690 /lib/libgcc_s.so.1
7fa394939000-7fa394b39000 ---p 00016000 08:05 3612690 /lib/libgcc_s.so.1
7fa394b39000-7fa394b3a000 r--p 00016000 08:05 3612690 /lib/libgcc_s.so.1
7fa394b3a000-7fa394b3b000 rw-p 00017000 08:05 3612690 /lib/libgcc_s.so.1
7fa394b3b000-7fa394bbf000 r-xp 00000000 08:05 3612744 /lib/libm-2.8.90.so
7fa394bbf000-7fa394dbe000 ---p 00084000 08:05 3612744 /lib/libm-2.8.90.so
7fa394dbe000-7fa394dbf000 r--p 00083000 08:05 3612744 /lib/libm-2.8.90.so
7fa394dbf000-7fa394dc0000 rw-p 00084000 08:05 3612744 /lib/libm-2.8.90.so
7fa394dc0000-7fa394eb1000 r-xp 00000000 08:05 2080932 /usr/lib/libstdc++.so.6.0.10
7fa394eb1000-7fa3950b1000 ---p 000f1000 08:05 2080932 /usr/lib/libstdc++.so.6.0.10
7fa3950b1000-7fa3950b8000 r--p 000f1000 08:05 2080932 /usr/lib/libstdc++.so.6.0.10
7fa3950b8000-7fa3950ba000 rw-p 000f8000 08:05 2080932 /usr/lib/libstdc++.so.6.0.10
7fa3950ba000-7fa3950cd000 rw-p 7fa3950ba000 00:00 0
7fa3950cd000-7fa3950e4000 r-xp 00000000 08:05 2083314 /usr/lib/libz.so.1.2.3.3
7fa3950e4000-7fa3952e3000 ---p 00017000 08:05 2083314 /usr/lib/libz.so.1.2.3.3
7fa3952e3000-7fa3952e5000 rw-p 00016000 08:05 2083314 /usr/lib/libz.so.1.2.3.3
7fa3952e5000-7fa395304000 r-xp 00000000 08:05 3612694 /lib/ld-2.8.90.so
7fa3954e9000-7fa3954ec000 rw-p 7fa3954e9000 00:00 0
7fa3954ff000-7fa395503000 rw-p 7fa3954ff000 00:00 0
7fa395503000-7fa395504000 r--p 0001e000 08:05 3612694 /lib/ld-2.8.90.so
7fa395504000-7fa395505000 rw-p 0001f000 08:05 3612694 /lib/ld-2.8.90.so
7fff9d4f0000-7fff9d505000 rw-p 7ffffffea000 00:00 0 [stack]
7fff9d5ff000-7fff9d600000 r-xp 7fff9d5ff000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
Aborted
** fail to run command '(cd maqdemo; /usr/local/bin/maq simustat easyrun/all.map > eval.simustat)' at /usr/local/bin/maq.pl line 842.

I am a newbie to bioinformatics. Is there anything wrong with the compilation? Or the configuration in my desktop should be changed? Your help will be highly appreciated.

Have a nice day!

Ms@New 06-28-2010 01:51 PM

Hi yuanlang,

Were you able to solve your problem?
I tried to run Maq's demo, but I ran to the same problem, right now,. I use a VERY small sequence, and I decreased number of simulated reads, but the problem still exists.

I'd appreciate any help I can get.

Thanks

Ms@New 06-28-2010 04:07 PM

I get the buffer overflow when it wants to run
usr/local/bin/maq simustat easyrun/all.map > eval.simustat

raela 06-29-2010 06:02 AM

Are you running 32 bit or 64 bit? If 32 bit, it might be an issue there. Also, did you just run maq.pl demo, or did you follow the instructions and download a genome and maq-data then do `maq.pl demo ref.fasta calib-36.dat`? I just ran it with no issues on my machine using equine chromosome M as my reference.

Ms@New 06-29-2010 07:56 AM

Thanks for your reply,

I'm running on a 32 bit.

I've downloaded calib.data, and found a bacterial genome. but after I got the buffer overflow, I decreased size of ref.fasta, and number of samples just to see if it runs!

right now it's a REALLY small sequence, with 1000 samples (the default is 1000000 samples in demo), and I get the results for previous steps in the demo, I can see the alignment result in maqview, so I consider it goes fine, up until "usr/local/bin/maq simustat easyrun/all.map > eval.simustat" command.

the 32-bit can be the problem?

thanks a lot for your help, I'm clueless

raela 06-29-2010 08:19 AM

That step doesn't look like it produces much data to me, but perhaps it's everything it takes in to run it. 32bit can cause buffer overflow issues - do you have access to a 64 bit machine? The 32 bit will probably cause you problems with analysis down the road.

Ms@New 06-29-2010 11:17 AM

I commented out the simustat line, and it runs now.

I'll try it on a 64 bit to see if that solves the problem or not.

thanks for your help.

R diggity 06-30-2010 12:50 PM

I'm having the same problem running on 64 bit Ubuntu 10.04. I've copied the necessary files into usr/local/bin and the simulation seems to work up until the same point as yuanlang posted.

raela 06-30-2010 12:54 PM

Could you provide a link to the bacterial genome you used? I'll try on the computer I have.

R diggity 06-30-2010 01:22 PM

http://www.ncbi.nlm.nih.gov/nuccore/NC_000962

So this is a test reference I've tried. If I remove the "simustat" line in the maqdemo script the run actually finishes. Does anyone know the cause of the original error? I'm just getting my feet wet with Maq, so I'm hoping to understand any issues that arise as early as possible before aligning any full-scale projects.

Thanks for any help!

raela 06-30-2010 06:34 PM

Well, I just ran the script with that genome with no issues, so I really don't know, sorry. Last advice I can give is make sure it's compiled as a 64 bit binary, in case ubuntu has multilib. Use which to find the path, then file to determine if it is. Example:

% which maq
/usr/local/bin/maq
% file /usr/local/bin/maq
/usr/local/bin/maq: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), not stripped

Ms@New 06-30-2010 09:04 PM

Hi R_diggy, I have the same problem,
Could you let me know if it was solved after doing
Quote:

Originally Posted by raela (Post 21150)
% which maq
/usr/local/bin/maq
% file /usr/local/bin/maq
/usr/local/bin/maq: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), not stripped

Thanks for the help Raela :)

R diggity 07-01-2010 04:24 AM

Thanks for the advice raela. I checked and it looks like I'm using the correct version:

/usr/local/bin/maq: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped

I tried a few runs last night using the reads produced in the demo (the part of the demo that worked...) and encountered no issues using the easyrun command.


All times are GMT -8. The time now is 06:54 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.