SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   Error while running ContEst (http://seqanswers.com/forums/showthread.php?t=25874)

ersgupta 12-18-2012 11:18 PM

Error while running ContEst
 
I am trying to run ContEst(http://www.broadinstitute.org/cancer/cga/contest)

Below is the command and options I used:

java -Xmx1200m -jar ContEst.jar \
-T Contamination \
-I test.bam \
-R hg19_GATK_Ref.fa \
-L target_bed_file.bed \
-B:pop,vcf hg19_population_stratified_af_hapmap_3.3.with.chr.vcf \
-B:genotypes,vcf test.vcf \
-BTI genotypes \
-o test.vcf.contest.out.txt

Here is the error report:

INFO 17:18:47,638 TraversalEngine - chr15:65621857 1.48e+06 5.2 m 3.5 m 72.4% 7.2 m 119.5 s
##### ERROR ------------------------------------------------------------------------------------------
##### ERROR stack trace
java.lang.ArrayIndexOutOfBoundsException: 0
at org.broadinstitute.cga.tools.gatk.walkers.cancer.contamination.ContaminationWalker.map(Unknown Source)
at org.broadinstitute.cga.tools.gatk.walkers.cancer.contamination.ContaminationWalker.map(Unknown Source)
at org.broadinstitute.sting.gatk.traversals.TraverseLoci.traverse(TraverseLoci.java:78)
at org.broadinstitute.sting.gatk.traversals.TraverseLoci.traverse(TraverseLoci.java:19)
at org.broadinstitute.sting.gatk.executive.LinearMicroScheduler.execute(LinearMicroScheduler.java:62)
at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute(GenomeAnalysisEngine.java:234)
at org.broadinstitute.sting.gatk.CommandLineExecutable.execute(CommandLineExecutable.java:113)
at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:221)
at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:87)
##### ERROR ------------------------------------------------------------------------------------------

It seems to be some issue with chr15 because I tried it with 3 different bams files and the reference used to generate those bams is also same(same as the one I used with ContEst).

I am unable to find any such issue reported by anyone else.

Anybody else having this issue or knows a way around ??

venkateshkp 08-05-2013 02:36 AM

Even I had the same error while running ContEst exactly at chr14-15.
Try it out with smaller bam files it works!

Anybody solved this error?


All times are GMT -8. The time now is 11:54 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.