SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   RNA Sequencing (http://seqanswers.com/forums/forumdisplay.php?f=26)
-   -   tophat error with -G option (http://seqanswers.com/forums/showthread.php?t=49295)

bbm 01-01-2015 05:28 AM

tophat error with -G option
 
Hello all,

I'm trying to use tophat to run alignment.

Tophat version: tophat/2.0.12
Bowtie version: bowtie2/2.2.1

here is my command line for the job:
tophat -G amel_OGSv3.2.gff3 --no-novel-juncs /gpfs_share/xxxx/xxxx/trim/xxxx.fastq

Below is the error I got:
-----------

[2015-01-01 09:22:31] Beginning TopHat run (v2.0.12)
-----------------------------------------------
[2015-01-01 09:22:31] Checking for Bowtie
Bowtie version: 2.2.1.0
[2015-01-01 09:22:31] Checking for Samtools
Samtools version: 0.1.19.0
[2015-01-01 09:22:31] Checking for Bowtie index files (genome)..
[2015-01-01 09:22:31] Checking for reference FASTA file
[2015-01-01 09:22:31] Generating SAM header for Am_genome
Traceback (most recent call last):
File "/usr/local/apps/tophat/2.0.12-gcc454/bin/tophat", line 4087, in <module>
sys.exit(main())
File "/usr/local/apps/tophat/2.0.12-gcc454/bin/tophat", line 3941, in main
params.read_params = check_reads_format(params, reads_list)
File "/usr/local/apps/tophat/2.0.12-gcc454/bin/tophat", line 1836, in check_reads_format
zf = ZReader(f_name, params)
File "/usr/local/apps/tophat/2.0.12-gcc454/bin/tophat", line 1789, in __init__
self.file=open(filename)
IOError: [Errno 2] No such file or directory: '-G'
-------
I have checked the first column of my gff3 and bowtie2 index, and they match.

I'm running this on a cluster.

thank you so much.


Regards,
bbm

GenoMax 01-01-2015 05:57 AM

Try providing full path to gff file. Is that directory available on the node where your job actually is running?

bbm 01-01-2015 06:51 AM

Quote:

Originally Posted by GenoMax (Post 157349)
Try providing full path to gff file. Is that directory available on the node where your job actually is running?

Thanks! I tried providing full path too, and have the same error.
The gff3 file is in current dir.

GenoMax 01-01-2015 07:53 AM

Can you provide the full command you are using (example above seems to be truncated, obfuscate names if you don't want to provide specifics)?

Are you using latest tophat? Are you able to run TopHat with just the -G option without providing reads (so the transcriptome index can be pre-built?)

From TopHat manual

Quote:

For example, in order to just prepare the transcriptome index files for a specific annotation, an initial, single TopHat run could be invoked like this:
tophat -G known_genes.gtf \
--transcriptome-index=transcriptome_data/known \
hg19
In this example TopHat will create the transcriptome_data directory in the current directory (if it doesn't exist already) containing files known.gff, known.fa, known.fa.tlst, known.fa.ver and the known.* Bowtie index files. Then for subsequent TopHat runs with the same genome and known transcripts but different reads, TopHat will no longer spend time building the transcriptome index because it can use the previously built transcriptome index files, so the -G option is no longer needed (however using it again will not force TopHat to rebuild the transcriptome index files if they are already present and with the matching version)


All times are GMT -8. The time now is 06:03 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.