SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   VarScan early halt (http://seqanswers.com/forums/showthread.php?t=26699)

allnovels 01-20-2013 11:40 AM

VarScan early halt
 
Hi,

I'm new to VarScan. I was trying to call copynumber from my exome sequencing data.

My script is
samtools mpileup -q 1 -f ~/hg19.fa normal.rmdup.bam tumor.rmdup.bam | java -Xmx4g -jar ~/VarScan.v2.3.3.jar copynumber > output --mpileup 1

It seems to run the first bit of the program and start to generate 2 files
1. copynumber
But it halted when it went to
chrM 16066 16165 100 53.7 89.7 0.740 1.0

The other file 30.copynumber only has the column name
chrom chr_start chr_stop num_positions normal_depth tumor_depth log2_ratio gc_content

Running message is as following:
[mpileup] 1 samples in 2 input files
<mpileup> Set max per-file depth to 8000
Min coverage: 10
Min avg qual: 15
P-value thresh: 0.01
Reading input from STDIN
Reading mpileup input...
Parsing Exception on line:
chrM 16184 C 0 0
8

It seems that something happened at the site chrM 16184... But I used my bam files to call SNPs/coverage from gatk and they worked out fine... I didn't know what's wrong...

Many thanks,
John

dkoboldt 01-30-2013 09:37 AM

John,

I would restructure your command slightly so that redirecting the output is the last thing you do... VarScan might not be interpreting your "--mpileup 1" :
samtools mpileup -q 1 -f ~/hg19.fa normal.rmdup.bam tumor.rmdup.bam | java -Xmx4g -jar ~/VarScan.v2.3.3.jar copynumber --mpileup 1 > output

If this doesn't help, I believe the issue occurs at a position where you have 0x coverage... those usually aren't present in pileup files. Please send me the mpileup lines for chrM from positions 16180- 16190 and I'll take a look.

Feel free to post here or e-mail to dkoboldt (at) genome [dot] wustl [dot] edu

lovenlong 12-23-2013 11:01 PM

Hi, all !

Though this thread had been posted about one year ago, I'd like to share my recent experience in meeting the same error in using Varscan2.
The causal thing would be the inconsistent of samtools version in generating BAMs and producing mpileup files.
In my case, input BAMs were generated by samtools-0.1.18 in weeks ago, while now the samtools version in my PATH is 0.1.19, and the error arised if I don't specify to use the samtools-0.1.18 in generating pileup file.

Thanks a bunch!


All times are GMT -8. The time now is 08:21 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.