SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   GeneMark-ES exits with "error, file not found: info/training.fna" (http://seqanswers.com/forums/showthread.php?t=77110)

gauravdube 07-17-2017 02:05 AM

GeneMark-ES exits with "error, file not found: info/training.fna"
 
Dear All,
I am trying to use GeneMark-ES Suite 4.32 to predict genes from a fungal genome. But GeneMark exits with:

Quote:

error, file not found: info/training.fna
To run the program, I am using the following command:

PHP Code:

./gmes_petap.pl --ES --fungus --sequence CBS_contigs.fasta.masked 

The log file 'gmes.log' contains the following:

Quote:

gmes_petap.pl : [Mon Jul 17 14:19:04 2017] /home/gaurav/2_GeneMark_results/gmes_petap/probuild --reformat_fasta --uppercase --allow_x --letters_per_line 60 --out data/dna.fna --label _dna --trace info/dna.trace --in /home/gaurav/1_Masking_Genome/CBS/CBS_contigs.fasta.masked

gmes_petap.pl : [Mon Jul 17 14:19:04 2017] /home/gaurav/2_GeneMark_results/gmes_petap/probuild --seq data/dna.fna --allow_x --stat info/dna.general

gmes_petap.pl : [Mon Jul 17 14:19:05 2017] /home/gaurav/2_GeneMark_results/gmes_petap/probuild --seq data/dna.fna --allow_x --stat_fasta info/dna.multi_fasta

gmes_petap.pl : [Mon Jul 17 14:19:05 2017] /home/gaurav/2_GeneMark_results/gmes_petap/probuild --seq data/dna.fna --allow_x --substring_n_distr info/dna.gap_distr

gmes_petap.pl : [Mon Jul 17 14:19:06 2017] /home/gaurav/2_GeneMark_results/gmes_petap/gc_distr.pl --in data/dna.fna --out info/dna.gc.csv --w 1000,8000

gmes_petap.pl : [Mon Jul 17 14:19:06 2017] /home/gaurav/2_GeneMark_results/gmes_petap/probuild --seq /home/gaurav/2_GeneMark_results/gmes_petap/data/dna.fna --split dna.fa --max_contig 5000000 --min_contig 50000 --letters_per_line 100 --split_at_n 5000 --split_at_x 5000 --allow_x --x_to_n --trace ../../info/training.trace
I have tried troubleshooting this error, but it did not resolved. Please help me resolve this error. Let me know if you need any further information. (I have even configured GeneMark-ET with the Braker pipeline, it works fantastic there. But I don't know what's the problem with GeneMark-ES over here.) Any help is appreciated. Thanks in advance.

GenoMax 07-17-2017 04:38 AM

The error is about the program not finding this file "../../info/training.trace". Is that file present in location relative to the directory you are running your command from?

gauravdube 07-19-2017 01:09 AM

Quote:

Originally Posted by GenoMax (Post 209323)
The error is about the program not finding this file "../../info/training.trace". Is that file present in location relative to the directory you are running your command from?

Hi GenoMax,

After posting, I have used the same command on another assembly which has better genome statistics than the previous one and it worked !!! It seems the problem is with 'probuild', as it requires atleast 10Mb of good data for training (ref: [https://www.researchgate.net/post/Genemark-ES_error]), which could not be retrieved from the poor assemblies. So I used AUGUSTUS instead for the poor ones and it is working. Anyway, thats the max I can make out of poor ones.

Thanks.


All times are GMT -8. The time now is 03:29 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.