SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   fastx-toolkit Abort trap: 6 error (http://seqanswers.com/forums/showthread.php?t=49720)

loloyohe 01-21-2015 12:11 PM

fastx-toolkit Abort trap: 6 error
 
Hi everyone!

Running the fastx-toolkit for my HiSeq data--using the standard protocol I have been in the past for previous data.

When I run fastq_quality_filter on Mac OSX Mavericks, I get a maddening error:

fastq_quality_filter -i seq_1.fq -o seq_1_fastxtrimmed.fastq -q 20 -p 80 -Q 33 -v
Abort trap: 6

When I use sudo with the command, the error goes away but the command still does not run. I have tried uninstalling and re-installing fastx-toolkit. Anyone else have this issue? Is this a problem with fastx-toolkit on Mavericks? I've been Googling for hours but it has not helped. Thanks!:)

GenoMax 01-21-2015 04:28 PM

Have you tried to recompile from source?

loloyohe 01-21-2015 05:16 PM

I have installed fastx-toolkit with homebrew. I uninstalled with homebrew and then reinstalled it in homebrew. I also upgraded the fastx-toolkit within homebrew, so in theory all of this brewing involves recompiling. I could try from scratch installing, but wanted to see if other people have also run into the issue.

loloyohe 01-22-2015 10:33 AM

Update: I have uninstalled all associated homebrew versions and then reinstalled and recompiled completely from source. Still have the same error. :(

Brian Bushnell 01-22-2015 12:00 PM

Well... fastx has some disadvantages in terms of speed and lack of support for paired files, not to mention the fact that it uses a sub-par trimming algorithm. You might try BBDuk, which runs on Mac without needing recompilation, does quality-trimming or filtering much faster than fastx, and supports paired reads.

GenoMax 01-22-2015 12:06 PM

No arguments on BBDuk ..

As noted in the original post, loloyohe is trying to follow a previously established protocol which used fastx.

@loloyohe: Is the current dataset significantly larger?

loloyohe 01-22-2015 02:42 PM

Thank you, both for the reply. The new files are ~8GB compared to the previous of 4GB so I suppose a memory issue is possible. Something tells me it is a compiling and compatibility issue with Mavericks. I uninstalled the most recent versions and reverted to the previous version in the hopes it was more stable. A new set of errors, but after troubleshooting the installation fastx-toolkit functions appear to be working fine. I have posted a resolution here. I can't say it "solved" the problem, but at least people can move forward.

Brian, while troubleshooting fastx-toolkit, I have BBtools up and running and trimming! Thanks for the suggestion--it seems like a better option for me and I look forward to seeing what it can do! :o

AlexReynolds 01-23-2015 01:30 PM

That error usually means that the process ran out of usable memory. This can be due to either the program trying to allocate more space than is available, or there is a memory leak that is exposed with a larger input file. You might contact the developers and file a report.


All times are GMT -8. The time now is 11:32 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.