SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   CummeRbund error without CDS (http://seqanswers.com/forums/showthread.php?t=18171)

dvanic 03-05-2012 04:15 AM

CummeRbund error without CDS
 
Hi! I'm trying to run cummeRbund on a cufflinks dataset without a reference annotation of any sort (i.e. just the transcripts assembled from bowtie/tophat results), which leads to my cds.diff being empty.
Hence, I get the following error when trying to create a cummeRbund database:

Quote:

Writing CDS table
Error in sqliteExecStatement(con, statement, bind.data) :
bind.data must have non-zero dimensions
How do I get around this (other than by using a reference annotation)? I'd still like to be able to explore the gene/tss/isoform information?

Thanks in advance!

lgoff 03-06-2012 02:58 PM

Hi dvanic,
This has been addressed in the development version of cummeRbund. (now v1.1.3). Please try updating to the new version and see if this resolves this issue.

compbio.mit.edu/cummeRbund

Cheers,
Loyal

christophe 03-11-2012 11:45 PM

Hi loyal Goff,
I have been trying running CummeRbund. As suggested I installed the latest version of cummeRbund (v1.1.3) within R 2.15.0 . The Error << Error in data.frame(index = c(1:length(samples)), sample_name = samples) arguments imply differing number of rows: 2, 0
Calls: readCufflinks -> loadGenes -> populateSampleTable -> data.frame
>>
disappeared , but a new one showed up as copied below:
NOTE: my working directory is the ouput directory of cuffdiff. I have to mention that CDS, promoter and TSS files are empty in my case. Only Isoforms and Genes files contain results.



Loading required package: RSQLite
Loading required package: methods
Loading required package: DBI
Loading required package: ggplot2
Loading required package: reshape2
Creating database /cuffdiff_outputs/cuffData.db
Reading /cuffdiff_outputs/genes.fpkm_tracking
Checking samples table...
Populating samples table...
Writing genes table
Reshaping geneData table
Recasting
Error in as.data.frame(cast(genemelt, ... ~ measurement)) :
could not find function "cast"
Calls: readCufflinks -> loadGenes -> as.data.frame



Thanks for your help.
Best,
Christophe

christophe 03-11-2012 11:47 PM

Addendum to my previous post:
I have tried to run cummeRbund both on linux and Windows and got the same error:

Error in as.data.frame(cast(genemelt, ... ~ measurement)) :
could not find function "cast"
Calls: readCufflinks -> loadGenes -> as.data.frame
Execution halted

lgoff 03-12-2012 07:54 AM

Temp fix
 
Hi cristophe,
This was a bug inadvertently created when I switched to reshape2. I have fixed it for future releases, but for now, the workaround is to import the original 'reshape' library before calling 'readCufflinks':

Code:

>library(cummeRbund)
>library(reshape)
>cuff<-readCufflinks()

Let me know if this doesn't work.

Cheers,
Loyal

christophe 03-12-2012 10:24 AM

Hi Loyal,
That works.
Only reshape2 was loading automatically and not reshape.
Thanks
Christophe


All times are GMT -8. The time now is 02:04 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.