SEQanswers (
-   RNA Sequencing (
-   -   STAR Aligner quantMode and fatal error (

NDUFB11 03-26-2019 06:46 PM

STAR Aligner quantMode and fatal error
Hello Everyone,

I have problems with STAR aligner.
I want to use the quantMode option in order to have .tab file that I will use for later analysis.

The first thing I did is the index of the genome:


STAR --runMode genomeGenerate --genomeDir genome/star/ --genomeFastaFiles /genome/Homo_sapiens.GRCh37.75.fa --sjdbGTFfile /genome/Homo_sapiens.GRCh37.75.gtf --runThreadN 20 --sjdbGTFtagExonParentTranscript Parent --sjdbGTFfeatureExon CDS --outFileNamePrefix genome/star/

from where I obtained this list of files


total 382248
-rw-rw-r--. 1        617 Mar 26 23:06 chrLength.txt
-rw-rw-r--. 1      1330 Mar 26 23:06 chrNameLength.txt
-rw-rw-r--. 1        713 Mar 26 23:06 chrName.txt
-rw-rw-r--. 1      919 Mar 26 23:06 chrStart.txt
-rw-rw-r--. 1      22187668 Mar 26 23:22
-rw-rw-r--. 1      21831277 Mar 26 23:22
-rw-rw-r--. 1    784390 Mar 26 23:22
-rw-rw-r--. 1        346597481 Mar 26 23:22 Log.out
drwx------. 2        6 Mar 26 23:05 _STARtmp
-rw-rw-r--. 1        0 Mar 26 23:22

then I run my sample


STAR --genomeDir genome/star --readFilesIn my_fastq/Treated_1_m1.fastq.gz my_fastq/Treated_1_m2.fastq.gz --outSAMtype BAM SortedByCoordinate --sjdbGTFfile genome/Homo_sapiens.GRCh37.75.gtf --quantMode TranscriptomeSAM GeneCounts --twopassMode Basic –alignIntronMax 15000 --outFilterIntronMotifs RemoveNoncanonical --runThreadN 20 --sjdbGTFtagExonParentTranscript Parent --sjdbGTFfeatureExon CDS --outReadsUnmapped fastx --readFilesCommand zcat
and I have this error,


Mar 27 03:32:36 ..... started STAR run
Mar 27 03:32:36 ..... loading genome

EXITING because of FATAL ERROR: could not open genome file genome/star2/genomeParameters.txt
SOLUTION: check that the path to genome files, specified in --genomeDir is correct and the files are present, and have user read permsissions

Mar 27 03:32:36 ...... FATAL ERROR, exiting

It seems like that he can not find the genomeParameters.txt file but was not even created during the indexing.

Does anybody had a similar problem or knows the solution?

Thank you for help

GenoMax 03-27-2019 03:53 AM

See this:

Use full path for genome dir in your command.

NDUFB11 03-27-2019 06:01 AM

Hi GenoMax,

unfortunately writing the entire path didn't help,

there must be something in my index structure command line that need to be adjusted I guess.

the problem is that if I want to use the option


--quantMode TranscriptomeSAM GeneCounts
I need to use the fasta format along with the GTF format for the index, otherwise I can get the genomeParameters.txt by using only the fasta format
Thank you for you answer anyways

sklages 04-04-2019 09:17 PM

Looks like your genome generation failed. There are missing quite a few files.

Have a look at

Are you seeing some errors?
Usually it should finish with sth. like:

Mar 13 17:07:06 ..... finished successfully
DONE: Genome generation, EXITING
And yes, just to be sure, I'd also use absolute paths as parameters ..

NDUFB11 04-09-2019 10:38 AM

Hi sklages,
I solved the problem by skipping TrascriptomeSAM,
running just this:

--quantMode GeneCounts

Thank you :)

All times are GMT -8. The time now is 02:56 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.