SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   bowtie index problem (bowtie-build and then bowtie-inspect) (http://seqanswers.com/forums/showthread.php?t=16469)

tgenahmet 12-26-2011 09:02 AM

bowtie index problem (bowtie-build and then bowtie-inspect)
 
I used bowtie-build to build an index:
Code:

~/bin/bowtie/bowtie-build human_g1k_v37.fa human_g1k_v37
It seemed to complete just fine:
Quote:

ebwtTotLen: 818510080
ebwtTotSz: 818510080
reverse: 0
Total time for backward call to driver() for mirror index: 05:24:17
Created these files:
Quote:

-rw-r--r-- 1 akurdogl asiniard 684M Dec 25 09:33 human_g1k_v37.4.ebwt
-rw-r--r-- 1 akurdogl asiniard 3.7K Dec 25 09:33 human_g1k_v37.3.ebwt
-rw-r--r-- 1 akurdogl asiniard 829M Dec 25 16:58 human_g1k_v37.1.ebwt
-rw-r--r-- 1 akurdogl asiniard 361M Dec 25 16:58 human_g1k_v37.2.ebwt
-rw-r--r-- 1 akurdogl asiniard 785M Dec 25 22:23 human_g1k_v37.rev.1.ebwt
-rw-r--r-- 1 akurdogl asiniard 342M Dec 25 22:23 human_g1k_v37.rev.2.ebwt
But when I run bowtie-inspect:
Code:

bowtie-inspect human_g1k_v37
It immediately crashes with this error:
Quote:

assert_eq: expected (1, 0x1) got (84, 0x54)
bowtie_inspect.cpp:242
bowtie-inspect: bowtie_inspect.cpp:242: void print_ref_sequences(std::ostream&, bool, const std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&, const uint32_t*, const std::string&): Assertion `0' failed.
Aborted
Or if I run:
Code:

bowtie-inspect -s human_g1k_v37
I get this:
Quote:

Colorspace 0
SA-Sample 1 in 32
FTab-Chars 10
Sequence-1 ?M???F=?w?Q???!~? /m?_}u?????w??}?????_o?C_Q??stߕ[5?{d??]?q??w?t?}g?>0 249250621
Sequence-2 x??x?????????????????????????????...
Any help is appreciated.

Shishir 02-15-2013 04:18 AM

Query
 
I am getting the same problem :( . Could you please let me know how you solved this?

Thanks

OTU 09-10-2013 09:52 AM

Bowtie_build - internal exception#1
 
Hello All!

I am having troubles running bowtie_build.
I am running:
bowtie2-build /scratch/annet/Sdata/SSURefSilva.fa SSURef \
> /scratch/annet/Sdata/SSURefSilva.fa

And I am getting this error message:
Reference file does not seem to be a FASTA file
Error: Encountered internal Bowtie 2 exception (#1)
Command: /opt/local/software/Genome/bowtie2/2.0.0-beta7/bin/bowtie2-build /scratch/annet/Sdata/SSURefSilva.fa SSURef

But my fasta file is ok, I know it!

Does anybody know what can be the problem???
Please!!!!!!:(

mastal 09-10-2013 10:32 AM

according to the Bowtie2 manual,
the format of the bowtie-build statement should be

Code:

bowtie2-build [options]* <reference_in> <bt2_base>
You might want to use the option -f to specify that your reference is in fasta format.

OTU 09-10-2013 11:51 AM

Ok! Thank you very much!!!


All times are GMT -8. The time now is 10:23 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.