SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   fastx-clipper to remove adapters problem (http://seqanswers.com/forums/showthread.php?t=35269)

mihuzx 11-11-2013 02:13 AM

fastx-clipper to remove adapters problem
 
Hi everyone,
today I tried to remove adapters using fastx-cliper, it worked all right, but the result is a little confused. here is the situation:
first I check the sequence quality using fastqc, and it said there is an Overrepresented sequences
AGATCGGAAGAGCACACGTCTGAACTCCAGTCACAGAGATCTATCTCGT, 7500 counts, and the Possible Source is TruSeq Adapter, Index 5 (97% over 37bp).
so I want to remove the adapter using fastx-cliper. and the command is
fastx_cliper -a Adaper_seq -C -i input.fastq -o outfile.fastq
but it removed much more than 7500 reads (about 20000 reads), and it also trimmed many other reads whitch contain part of the adapter. so the outputfile contain all length reads instead of equal lengh reads. in addition, it also remove a lot of short (<5bp) reads, but the reads in input file were all equal.
there must be something wrong, and did I used the wrong parameters? could I only remove the reads containing the whole adapter? and if I want to do so, can the fastx-toolkit do this job? or is there some other tools to recommend

thanks a lot!


All times are GMT -8. The time now is 08:07 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.