SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   Java problem when using BBmap (http://seqanswers.com/forums/showthread.php?t=78744)

Lukas Hellmann 10-23-2017 04:52 AM

Java problem when using BBmap
 
Hi guys,

I am working on a cluster that was changed to CentOS 7.3.1611 and SLURM scheduler recently. Since the change I cannot use any of the BBmap tools any longer, they all quit with a java error.

For example:
bbduk.sh -Xmx400m in=test.fq out=out.fq ftl=10

results in:
Error occurred during initialization of VM
Could not reserve enough space for 819200KB object heap
srun: error: a0150: task 0: Exited with exit code 1
srun: Terminating job step 3196181.0

I have Java 1.8.0_121 installed. Using the -Xms flag did not solve the problem either.

Any ideas how to tackle the problem?

GenoMax 10-23-2017 04:55 AM

Are you assigning memory e.g. "--mem=4g" (or the appropriate amount) in your SLURM command?

I regularly use bbmap with SLURM and have not had any issues.

Lukas Hellmann 10-23-2017 05:10 AM

Yes, I assign memory. I even tried to request huge excess memory to fulfill java requirements, but that did not help. I don't think job submission is the problem, as I have no issues with any other software.

The OS was changed in addition. I suppose this causes the problems.

GenoMax 10-23-2017 05:21 AM

I also use CentOS so that should not be a problem. Have you tried to talk with your sys admins? Are you able to run the jobs directly outside SLURM?

Lukas Hellmann 10-23-2017 05:23 AM

java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)


All times are GMT -8. The time now is 05:38 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.