SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   error from SOAPdenovo (http://seqanswers.com/forums/showthread.php?t=12732)

shuang 07-14-2011 08:41 AM

error from SOAPdenovo
 
When I tried to run SOAPdenovo with a command "./SOAPdenovo all -s SB1.config -K 25 -o output", I received an error message of "-bash: ./SOAPdenovo: No such file or directory".

Why?



This is the content of SB1.config.

#maximal read length
# Lines start with '#' are ignored by the assembler
max_rd_len=50
[LIB]
avg_ins=2000
reverse_seq=1
asm_flags=2
rank=2
# cutoff of pair number for a reliable connection
#(default 5 for large insert size)
pair_num_cutoff=5
#minimal mapped length to contigs for a reliable read location
#(default 35 for large insert size)
map_len=35
q1=/Users/Steve/bin/SOAPdenovo_1.03/SB_short.fastq

nickloman 07-14-2011 11:53 AM

Well, er, the obvious question first - is SOAPdenovo in your current directory?

Confirm with ls -l SOAPdenovo

If not you will need to refer to it by the complete path, i.e. /Users/Steve/path/to/SOAPdenovo

Secondly, check the execute permissions are set, e.g. chmod 755 SOAPdenovo

Hope that helps

shuang 07-14-2011 12:44 PM

I tried all 3 things you suggested. But still getting the same error message, cannot execute binary file.

Any other suggestions?

nickloman 07-14-2011 01:04 PM

Make sure you have downloaded the right binary for your system, check uname -a & uname -p to see. If running on Linux make sure you got the correct 32 or 64-bit versions.

seb567 07-14-2011 04:31 PM

The problem is simply that there is no such file or directory.

Otherwise this would happen:

seb@fault:~/software/SOAPdenovo-PPC$ file SOAPdenovo-31mer
SOAPdenovo-31mer: ELF 64-bit MSB executable, 64-bit PowerPC or cisco 7500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped

seb@fault:~/software/SOAPdenovo-PPC$ uname -m
i686

seb@fault:~/software/SOAPdenovo-PPC$ ./SOAPdenovo-31mer
bash: ./SOAPdenovo-31mer: cannot execute binary file

nickloman 07-15-2011 12:08 AM

Seb makes a good point.

Can you go into the directory you wish to execute SOAPdenovo from and paste the output of the following commands to this thread:

ls -l

uname -a

uname -m

file SOAPdenovo

shuang 07-15-2011 07:43 AM

I checked my Mac. My Mac is 10.6.3. It seems eligible for the newest release 1.05, which requires Mac OS X, 10.6.5 or later.

Thus, I downloaded Release 1.04 for Mac OS X (64 bit version, above 10.5). However, when I tried to extracted the file with this command:
tar -zxvf SOAPdenovo-v1.04-macos-64.tgz

However, I received this error during the process.

grape_mac_64
tar: A lone zero block at 521


I also tried Mac OS X (32 bit version, above 10.5) and had similar error.

grape_mac_32
tar: A lone zero block at 574

How to I fix this issue? Thanks.


All times are GMT -8. The time now is 09:17 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.