SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   SHRiMP with FASTAQ input (http://seqanswers.com/forums/showthread.php?t=18443)

CS Student 03-15-2012 10:37 AM

SHRiMP with FASTAQ input
 
Dear all,

I am trying to run SHRiMP with FASTAQ input files using the -Q option.

Here is the command I am using:

/home/user/SHRiMP_2_2_2/bin/gmapper-ls /home/user/SHRiMP_2_2_2/reads.phi.x.174.fastq /home/user/SHRiMP_2_2_2/phi.x.174.fa -Q -V -N 1 -o 5 -h 80% > /home/user/SHRiMP_2_2_2/output/map.0_to_2499999.out 2> /home/user/SHRiMP_2_2_2/output/map.0_to_2499999.log


And here is the error I am getting:
- Processing genome file [/home/user/SHRiMP_2_2_2/phi.x.174.fa]
- Processing contig phi.x.174
Loaded Genome
note: detected fastq format in input file [/home/user/SHRiMP_2_2_2/reads.phi.x.174.fastq]
- Processing read file [/home/user/SHRiMP_2_2_2/reads.phi.x.174.fastq]
note: quality value format not set explicitly; using PHRED+64done r/hr r/core-hr
The qv-offset might be set incorrectly! Currenty qvs are interpreted as PHRED+64 and a qv of -14 was observed. To disable this error, etiher set the offset correctly or disable this check (see README).

Could you please advise on how to set the qv offset?
Thanks.

CS Student 03-15-2012 11:39 AM

I was able to solve this issue using the following two options:

1. --qv-offset 64: Interpret qvs in fastq input as PHRED+<value>. The default is 33 for colour space and 64 for letter space.

2. --ignore-qvs: When input is fastq, completely ignore base/colour qvs from the analysis, as if the input were fasta.


All times are GMT -8. The time now is 06:06 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.