SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   python new version not seen (http://seqanswers.com/forums/showthread.php?t=102008)

Pol2021 09-27-2021 06:31 AM

python new version not seen
 
Hello, I have installed python 3.9.1 and indeed this is confirmed in the terminal when looking to the version. However when launching Biopython I get the message "Biopython requires Python 3.6 or later. Python 2.7 detected." How is this possible? What to do? Thanks.

GenoMax 09-27-2021 07:14 AM

Python is generally symlinked to python v.2.x. Can you explicitly try `python3`?

AlexPhilip 09-27-2021 09:41 PM

New python versions usually break a lot of modules, especially low-level ones like pyinstaller and cffi. I usually wait for a revision or two before upgrading to let module maintainers catch up. Waiting also lets the PSF fix any bugs and security holes that are bound to be lurking somewhere.

QEO 10-05-2021 03:27 AM

The old version is better!


All times are GMT -8. The time now is 01:03 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.