SEQanswers (
-   Bioinformatics (
-   -   Help with bowtie2 for a beginner (windows) (

ruchi1621 10-23-2013 06:38 PM

Help with bowtie2 for a beginner (windows)
As I am completely new to the field of Next Generation Sequencing and I have absolutely no background in computers, I need your help in figuring out the mistakes that I am doing while conducting sequence alignment. I am using bowtie2. The command that I have entered is:

./bowtie2 -p 8 -x hg19 NA11881.fastq > Experiment1.sam

And the result that I get is:

0 reads
0.00% overall alignment rate

I know I am going wrong somewhere. Please help! Any links to help me solve this problem will be appreciated.

Thank you!

Kennels 10-23-2013 06:43 PM

Try specifying '-U' in front of your fastq file

ruchi1621 10-23-2013 06:46 PM

Still the same result.

Kennels 10-23-2013 07:01 PM

Try also putting '-q' option to specify it is fastq input.
If that still fails, what is the output from


head NA11881.fastq
some check questions:

Can you post any errors or warning you are getting?
Do you have all the index files in the same directory?
Do you have 8 cpus on your computer?

ruchi1621 10-23-2013 07:49 PM

I am not getting any output for "head NA11881.fastq"

I am not getting any errors or warnings

I have all the index files in the same directory

yes. I have 8 cpus on my computer

Kennels 10-23-2013 07:59 PM

Well there's your problem - your fastq file is empty.
The head command gets the first 10 lines from your file.

what do you get with:

ls -lh NA11881.fastq

ruchi1621 10-23-2013 08:01 PM

On entering:
ls -lh NA11881.fastq

i get

-rw-r--r-- 1 bansalr students 0 Oct 16 14:59 NA11881.fastq

ruchi1621 10-23-2013 08:05 PM

You are right. The file is empty. Let me transfer it again and re-try aligning it. I will get back to you regarding the success of the same. Thanks for your help!

Kennels 10-23-2013 08:06 PM

your file size is zero - between 'students' and 'Oct' .

You need to check where and how your downloaded your file. It should not be empty. Perhaps you can get it again from your source. Redo the above commands once you are sure you have reads to align. good luck.

ruchi1621 10-24-2013 10:18 AM

I transferred the downloaded the file again and redid the commands and it worked! Thank you so much for your help! :)

All times are GMT -8. The time now is 02:14 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.