SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   yet another "Error: segment-based junction search failed with err = -9" (http://seqanswers.com/forums/showthread.php?t=6503)

liux 08-21-2010 09:04 PM

Tophat error: "segment-based junction search failed with err = -9"
 
I have run into the same problem that are few people have encountered before when I am using TopHat to align 7 lanes of Illumina data to hg19. Since I am relatively new to tophat, can somebody give me a hint? Thanks!

here are the screen output and segment_juncs.log:

Code:

[Fri Aug 20 14:58:12 2010] Beginning TopHat run (v1.0.13)
-----------------------------------------------
[Fri Aug 20 14:58:12 2010] Preparing output location /home/haiti/tmpdata/all_brn/tophat/
[Fri Aug 20 14:58:12 2010] Checking for Bowtie index files
[Fri Aug 20 14:58:12 2010] Checking for reference FASTA file
[Fri Aug 20 14:58:12 2010] Checking for Bowtie
        Bowtie version:          0.12.5.0
[Fri Aug 20 14:58:12 2010] Checking reads
        seed length:    35bp
        format:          fastq
        quality scale:  phred33 (default)
[Fri Aug 20 15:31:58 2010] Reading known junctions from GFF file
        Warning: TopHat did not find any junctions in GFF file
[Fri Aug 20 15:53:49 2010] Mapping reads against hg19 with Bowtie
[Sat Aug 21 00:52:55 2010] Joining segment hits
[Sat Aug 21 01:22:40 2010] Searching for junctions via segment mapping
        [FAILED]
Error: segment-based junction search failed with err = -9

segment_juncs.log
Code:

segment_juncs v1.0.13
---------------------------
Loading reference sequences...
        Loading chr1...done
        Loading chr2...done
        Loading chr3...done
        Loading chr4...done
        Loading chr5...done
        Loading chr6...done
        Loading chr7...done
        Loading chr8...done
        Loading chr9...done
        Loading chr10...done
        Loading chr11...done
        Loading chr12...done
        Loading chr13...done
        Loading chr14...done
        Loading chr15...done
        Loading chr16...done
        Loading chr17...done
        Loading chr18...done
        Loading chr19...done
        Loading chr20...done
        Loading chr21...done
        Loading chr22...done
        Loading chrX...done
        Loading chrY...done
        Loading chrM...done
Found 0 potential split-segment junctions
Indexing extensions in /home/haiti/tmpdata/all_brn/tophat/tmp//left_kept_reads_missing.fq
Total extensions: 637479408
Looking for junctions by island end pairings
Adding hits from segment file 0 to coverage map
Map covers 325972654 bases
Map covers 320327918 bases in sufficiently long segments
Map contains 5580241 good islands
276495363 are left looking bases
276492492 are right looking bases
Collecting potential splice sites in islands


liux 08-24-2010 10:48 AM

However, when I run lanes individually, no problems were reported at all.

Anyone know the cause of the error?

right now, I am align lanes individually, and plan to merge, sort and index them once all alignments are done. does this route have any potential problem?

Thanks!


All times are GMT -8. The time now is 10:46 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.