SEQanswers (
-   Bioinformatics (
-   -   Maq: Segmentation Fault (

mrxcm3 11-08-2010 03:16 AM

Maq: Segmentation Fault

I am trying to map my SOLiD reads in Maq. I have converted my reads from .csfasta and .qual to .fastq using ''. I then generated a binary file using 'maq fastq2bfq'. I turned my reference genome (GRCh37) from .fa to .csfa using 'maq fasta2csfa' and made this binary using 'fasta2bfa'.

When I use 'maq map' I get a segmentation fault. There is no other information. Here is my command;

maq map -c ref.csbfa reads.bfq 2> aln.log

Does anyone have any ideas what could be causing this? I am currently using v0.7.1, but have tried the same command on earlier versions and get the same. I am wondering is the 'maq fasta2csfa' accepts reference in '.fa'?

TenchBB 03-21-2011 11:48 AM

I have recently experienced a similar problem. I am also attempting to use MAQ to map my SOLiD reads.

I had recieved the .fastq files from a collaborator so I first used "maq fastq2bfq" and "maq fasta2csfa" and then ran the following the command:

maq map -c ref.csbfa reads_1.bfq reads_2.bfq 2

I got back the following error:

-- maq-0.7.1
[ma_load_reads] loading reads...
[ma_load_reads] set length of the first read as 1.
[ma_load_reads] set length of the second read as 1.
maq: longreads_t* ma_load_reads(void*, int, void*, int): Assertion `strncmp(name, lr->name[j], tl-1) == 0' failed.

I then tried to go back a step and use the .csfasta and _QV.qual files to create the .fastq files using This ran with no error, howvever, the output files are empty!

I am stuck. Can anyone offer any advice??

Sincere thanks,


nilshomer 03-21-2011 02:43 PM

@TenchBB: Please do not double-post in two different forums (or here for that matter). Thank-you!

All times are GMT -8. The time now is 07:38 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.