SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   Newbler segmentation fault (http://seqanswers.com/forums/showthread.php?t=10637)

flobpf 04-08-2011 12:55 PM

Newbler segmentation fault
 
I'm using Newbler x86_64 version to assemble my 454 reads on a cluster machine. When I try to use this command:
Code:

addRun -lib 3kb_PE project2 GE3Z0RR02.sff
I keep on getting an instantaneous Segmentation fault error. I also noticed a (core dump) message before segmentation fault. Wikipedia says you get this error when program tries to access memory it is not allowed to.

What is the solution, though? I'm not even sure if Newbler is trying to do that since the error is almost instantaneous (its certainly not going above allocated usage). I am confused by this error...please help. Any suggestion will be useful

genelab 04-08-2011 07:14 PM

We once run into this error, when we run the Soap2.2. We used gdb to debug the error, and we found it is the libstd++.so library which was not compatible with the Soap2.20 executable program. I just think if you could use gdb to debug your addRun, like this:

gdb addRun -lib 3kb_PE project2 GE3Z0RR02.sff

flobpf 04-10-2011 02:10 PM

That worked...but did not quite solve the problem
 
Quote:

Originally Posted by genelab (Post 39152)
We once run into this error, when we run the Soap2.2. We used gdb to debug the error, and we found it is the libstd++.so library which was not compatible with the Soap2.20 executable program. I just think if you could use gdb to debug your addRun, like this:

gdb addRun -lib 3kb_PE project2 GE3Z0RR02.sff

@genelabs: Thanks for that suggestion! Atleast I know what is wrong now. I ran:
Code:

gdb addRun (followed by) run -lib 3kb_PE project2 GE3Z0RR02.sff
I got the following error:
Code:

warning: shared library handler failed to enable breakpoint

Program received signal SIGSEGV, Segmentation fault.
0x00000000004e3423 in ?? ()

Wonder what could be the issue??

Thanks for your help!

genelab 04-10-2011 06:59 PM

It seems that some problems exist in your gdb from the warning message "shared library handler failed to enable breakpoint". I am sorry I didn't encounte this kind of error message before and cannot give your beneficial suggestions. You can google it.

flobpf 04-18-2011 12:45 PM

Solved!
 
We finally realized that the FTP of the sequencing center that gave us the files was set to ASCII mode when it should have been set to binary mode. Fixing that fixed this problem.

If you're using Wget, by default it will use binary mode according to the manual.

Thanks @genelab for the helpful suggestions before...


All times are GMT -8. The time now is 09:02 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.