SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Illumina/Solexa (http://seqanswers.com/forums/forumdisplay.php?f=6)
-   -   problems configuring installation of Bcl2fastq (http://seqanswers.com/forums/showthread.php?t=58052)

jov14 04-28-2015 06:55 AM

problems configuring installation of Bcl2fastq
 
Hi,
I want to install Bcl2fastq on my system running Ubuntu 14.04.2 LTS. I have admin rights.

However the configure step always aborts with an error.

After running configure I first ran into the typical Error messages of "No support for gzip compression" and "No support for bzip2 compression", so i followed early recommendations here and here, and copied "libz.so", "libpthread*" and "libbz2.so" from /usr/lib/x86_64-linux-gnu/ to /usr/lib.

after that, running "configure" produced this new error message:
Code:

CMake Error at cmake/cxxConfigure.cmake:95 (message):
  libxml2 was not found

As this problem has not been discussed earlier, I tried to use the same approach by copying the libxml2-associated files to /user/lib using the following command:
Code:

sudo cp /usr/lib/x86_64-linux-gnu/libxml2* /usr/local/lib
As this did not help I followed the setup instruction at the end of this thread and this very helpful setup-script to ensure that all dependancies are met.

However I still get the same error message:
Code:

-- Could NOT find LibXml2 (missing:  LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR)
CMake Error at cmake/cxxConfigure.cmake:95 (message):
  libxml2 was not found
Call Stack (most recent call first):
  c++/CMakeLists.txt:33 (include)


-- Configuring incomplete, errors occurred!
Couldn't configure the project:

/tmp/bcl2fastq-build/bootstrap/bin/cmake -H"/tmp/bcl2fastq/src" -B"/tmp/bcl2fastq-build" -G"Unix Makefiles"  -DCASAVA_PREFIX:PATH=/usr/local/tools/bcl2fastq-1.8.4 -DCASAVA_EXEC_PREFIX:PATH= -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/tools/bcl2fastq-1.8.4 -DCASAVA_BINDIR:PATH= -DCASAVA_LIBDIR:PATH= -DCASAVA_LIBEXECDIR:PATH= -DCASAVA_INCLUDEDIR:PATH= -DCASAVA_DATADIR:PATH= -DCASAVA_DOCDIR:PATH= -DCASAVA_MANDIR:PATH= -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo

Moving CMakeCache.txt to CMakeCache.txt.removed

Any suggestions?

GenoMax 04-28-2015 07:05 AM

Start with

Code:

$ sudo apt-get install libxml2 libxml2-dev
see if that fixes the error.

jov14 04-28-2015 07:44 AM

Thanks a lot!
I was sure I had libxml2 installed, but i seem to have been mistaken...
Configure now completed without errors. However, now I run into the following errors during "make" at 51%
Code:

[ 51%] Building CXX object c++/lib/io/CMakeFiles/casava_io.dir/PtreeXml.cpp.o
/tmp/bcl2fastq/src/c++/lib/io/PtreeXml.cpp: In function std::ostream& casava::io::operator<<(std::ostream&, const ptree&):
/tmp/bcl2fastq/src/c++/lib/io/PtreeXml.cpp:123:123: error: no matching function for call to xml_writer_make_settings(char, int)
        boost::property_tree::write_xml(os, treeWithIndexAttributes, boost::property_tree::xml_writer_make_settings(' ', 2));

The final error message is:
Code:

make[2]: *** [c++/lib/io/CMakeFiles/casava_io.dir/PtreeXml.cpp.o] Error 1
make[1]: *** [c++/lib/io/CMakeFiles/casava_io.dir/all] Error 2
make: *** [all] Error 2

boost is definitively installed. Do you have suggestions for this also?

fanli 04-28-2015 07:54 AM

Might be an issue with your Boost version. From a different topic, but similar error:
https://github.com/mapnik/mapnik/issues/2365

I was able to install successfuly with Boost 1.55

jov14 04-28-2015 08:10 AM

I have boost version 1.54 installed, which seems to be the newest version of boost in the official Ubuntu repositories.
So I guess that means I should download the most current version of boost directly and compile it manually?
I'll try.

GenoMax 04-28-2015 08:11 AM

Illumina software is picky about version of boost libraries. A local copy here is using boost v.1.44 (which the software built itself).

jov14 04-28-2015 09:53 AM

Hi, everyone.
while trying to figure out how to install which boost library, I simultaneously tried the alternative approach of installing via the Illumina-supplied rpm-package using the instructions here

This now works fine, once expat-2.1.0 and xml-parser-2.41 were installed.

So right now, I am abandoning trying to compile bcl2fastq from source and just work with the successfully installed rpm-package version.

Thanks everyone!

liorgalanti 01-05-2018 03:08 PM

This is for the latest bcl2fastq version 2.20.0 but it seems to be a similar error.

http://backwardincompatible.com/post...on-ubuntu-with


All times are GMT -8. The time now is 01:36 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.