SEQanswers

SEQanswers (http://seqanswers.com/forums/index.php)
-   Bioinformatics (http://seqanswers.com/forums/forumdisplay.php?f=18)
-   -   Uploading BAM Track to UCSC Genome Browser (http://seqanswers.com/forums/showthread.php?t=5872)

jjw14 07-08-2010 12:35 PM

Uploading BAM Track to UCSC Genome Browser
 
I have built a bowtie index from the Nov. 2009 Sus scrofa draft assembly (SGSC Sscrofa9.2) that I downloaded from the UCSC website. I aligned my Illumina sequence reads to this index and output the results in SAM format.

I followed the instructions on the UCSC site for BAM Track Format (http://genome.ucsc.edu/goldenPath/help/bam.html), and all goes fine until step 6:

6. Construct a custom track using a single track line. The most basic version of the "track" line will look something like this:
track type=bam name="My BAM" bigDataUrl=http://myorg.edu/mylab/my.sorted.bam


My sorted BAM file (JJW.sorted.bam) and the associated index JJW.sorted.bam.bai are in the same web server directory (http), and I simply replace the UCSC URL/filenames with my own server and BAM file.

After pasting the custom track into the box labeled "paste URLs or data", the browser cycles for several minutes while uploading the file. After this, the web browser switches to a completely blank page (just white background). The url address in the web browser is "http://genome.ucsc.edu/cgi-bin/hgCustom"

I seem to be making an error in my custom track syntax. Can anyone provide the format or examples for the URLs / track information that should be included in the two boxes labeled "Paste URLs or Data:" and "Optional track documentation:"? I have read the UCSC help files but can't seem to get it right.

Many thanks in advance,
jjw

raela 07-09-2010 11:08 AM

I would double check the file is there and okay. Have you gone to the location in your browser window and seen if it asks you to download the file? If so, you should be good. I usually see that when I tell UCSC to use a non-BAM file (like pointing it to a bedGraph). track type=bam name=name bigDataUrl=http://blah/foo.bam has always been sufficient for me.

jjw14 07-09-2010 11:46 AM

Thanks for the feedback. You are correct. If I look up the http address of the file I am serving from a computer on campus, I can see and download the file fine. However, when I tried to access this file from my home computer, I get a time out error. I don't know enough about the campus NAT, firewall, router, VPN or whatever to get my files to the outside world. :mad: I understand the IT dept's position on security, but it's still frustrating. Guess I'll chew up my own bandwidth at home to try to get the files uploaded overnight while I sleep.

Everyone in this discussion community has been really helpful. It's a great resource made up of a lot of smart (and patient) individuals. Many thanks.

jjw

raela 07-09-2010 11:57 AM

Ah yes, didn't think about that, either.. I'm in the same boat, I've been hosting on my own network. One thing that helps me is filtering out unmatched reads, even if only for viewing on UCSC. I aligned to chromosomes in a genome, so all of my references were chr*. To filter, I did grep chr file.sam > file.noun.sam, then generated bam files from there.

Bumeaung50 02-01-2019 07:15 AM

Quote:

Originally Posted by jjw14 (Post 21583)
Thanks for the feedback. You are correct. If I look up the http address of the file I am serving from a computer on campus, I can see and download the file fine. However, when I tried to access this file from my home computer, I get a time out error. I don't know enough about the campus NAT, firewall, router, VPN or whatever to get my files to the outside world. :mad: I understand the IT dept's position on security, but it's still frustrating. Guess I'll chew up my own bandwidth at home to try to get the files uploaded overnight while I sleep.

Everyone in this discussion community has been really helpful. It's a great resource made up of a lot of smart (and patient) individuals. Many thanks.

jjw

I hope so,, I have a problem on my wireless router 'coz the site I open even here didn't get in my IP address. And the site that it cannot be reach. That why I decided to restart my wireless router make it well but after that my computer didn't recognize my IP address on my router.


All times are GMT -8. The time now is 01:51 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.