View Single Post
Old 01-27-2012, 08:14 AM   #1
SeqVicious
Member
 
Location: New Hampshire

Join Date: Sep 2011
Posts: 15
Default Samtools installation

Hi all,

I'm very new to bioinformatics and all I'm trying to do is index a bam file so I can view the pileup in IGV. I've downloaded the latest version of samtools unpacked it successfully. I'm now trying to install it but I'm running into an error after the 'make samtools' command. Make clean works just fine but the following error occurs after 'make samtools'.

$ make samtools
make[1]: Entering directory <path>
gcc -c -g -Wall -O2 -D_FILE_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1 -I. bgzf.o
In file included from bgzf.c:36:0:
gbzf.h:29:28: fatal error: zlib.h: No such file or directory
compilation terminated
Makefile:21: recipe for target 'bgzf.o' failed
make[1]: *** [bgzf.o] Error 1
make[1]: Leaving directory <path>
$CC= gcc
gcc: no input filesr] Error 1

It looks like it's having trouble with one of the files. Since I only need to be using a few of the samtools options can I just delete the files that give problems? I've also tried redownloading samtools a couple of times and the same error shows up.
SeqVicious is offline   Reply With Quote