View Single Post
Old 07-08-2010, 12:35 PM   #1
jjw14
Member
 
Location: Missouri

Join Date: Apr 2010
Posts: 39
Default Uploading BAM Track to UCSC Genome Browser

I have built a bowtie index from the Nov. 2009 Sus scrofa draft assembly (SGSC Sscrofa9.2) that I downloaded from the UCSC website. I aligned my Illumina sequence reads to this index and output the results in SAM format.

I followed the instructions on the UCSC site for BAM Track Format (http://genome.ucsc.edu/goldenPath/help/bam.html), and all goes fine until step 6:

6. Construct a custom track using a single track line. The most basic version of the "track" line will look something like this:
track type=bam name="My BAM" bigDataUrl=http://myorg.edu/mylab/my.sorted.bam


My sorted BAM file (JJW.sorted.bam) and the associated index JJW.sorted.bam.bai are in the same web server directory (http), and I simply replace the UCSC URL/filenames with my own server and BAM file.

After pasting the custom track into the box labeled "paste URLs or data", the browser cycles for several minutes while uploading the file. After this, the web browser switches to a completely blank page (just white background). The url address in the web browser is "http://genome.ucsc.edu/cgi-bin/hgCustom"

I seem to be making an error in my custom track syntax. Can anyone provide the format or examples for the URLs / track information that should be included in the two boxes labeled "Paste URLs or Data:" and "Optional track documentation:"? I have read the UCSC help files but can't seem to get it right.

Many thanks in advance,
jjw
jjw14 is offline   Reply With Quote