View Single Post
Old 08-14-2014, 05:05 AM   #31
wacguy
Member
 
Location: NC

Join Date: Sep 2012
Posts: 24
Default -p flag causes problems

Hi,

I'm running tohat2 against the sequence of my transgene (luciferase). I only use the bowtie2 indexes and the FASTA file (i.e., no GTF).
I realized that using the -p 2 (or more) comparing to no -p option (but I didn't try to explicitly run w/ -p 1) can sometimes (this is file related because it doesn't haapen w/ all files) spits the following error:
Reporting output tracks
[FAILED]
Error running /usr/libexec/tophat.

Another type of error occured on some files:

Warning: Empty fasta file: '/rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs.fa'
Warning: All fasta inputs were empty
Error: Encountered internal Bowtie 2 exception (#1)
Command: /usr/bin/bowtie2-build /rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs.fa /rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs
[FAILED]
Error: Splice sequence indexing failed with err =1

I solved it by the flag: --no-novel-juncs
It is starnge because according to tohat manual, this flag is ignored w/o the -j/G option but it solved the problem.

topaht version 2.0.9 or 2.012.
Good luck,
Guy
wacguy is offline   Reply With Quote