View Single Post
Old 12-18-2012, 02:15 AM   #1
syfo
Just a member
 
Location: Southern EU

Join Date: Nov 2012
Posts: 103
Default BEDtools intersect output is BED instead of BAM

Hi all,
I want to discard the reads that overlap some blacklist regions, so I use
intersectbed -abam -v -a readfile.bam -b badregions.bed

I get 9 entries in BED format, despite the abam option ("The A input file is in BAM format. Output will be BAM as well.")

Now if I add the -wa option I get 3.5M entries, again in BED format.

Any idea about what is going on?
thanks
syfo is offline   Reply With Quote