View Single Post
Old 03-01-2020, 10:53 PM   #1
bioramg
Member
 
Location: South Korea

Join Date: Apr 2014
Posts: 10
Default Spades: Failed to determine erroneous kmer threshold. Threshold set to: 22

Hi,
Thank you for developing SPAdes for hybrid assembly.

I tried to assemble Illumina pair-end with Oxford Nanopore Sequence for plant mitochondrial genome assembly.
Before carried out, I used BBMAP to trim adapters and normalize Illumina data. I have used the commands for trim adapters:
bbmap$ ./bbduk.sh -Xmx1g in=read1.fastq in2=read2.fastq out=trim_read1.fastq out2=trim_read2.fastq ktrim=r k=23 mink=11 hdist=1 ref=resources/adapters.fa tbo tpe

for normalize:
$./bbnorm.sh in=trim_read1.fastq in2=trim_read2.fastq out=norm_read1.fastq out2=norm_rread2.fastq target=100 min=5

Then, I used these Illumina pair-end reads with Oxford nanopore and the commands as follows:
$ ./spades.py -k 99 --pe1-1 norm_read1.fastq --pe1-2 norm_read2.fastq --nanopore nano_read.fastq --careful --cov-cutoff 90 -o hybrid_assembly -m 188.

When I run using this command, I have got an error message as:
======= SPAdes pipeline finished WITH WARNINGS!

=== Error correction and assembling warnings:
* 8:48:41.078 34G / 56G WARN General (kmer_coverage_model.cpp : 218) Too many erroneous kmers, the estimates might be unreliable
* 8:48:41.472 34G / 56G WARN General (kmer_coverage_model.cpp : 327) Valley value was estimated improperly, reset to 22
* 8:48:41.477 34G / 56G WARN General (kmer_coverage_model.cpp : 366) Failed to determine erroneous kmer threshold. Threshold set to: 22

I am herewith enclosing spades.log file for your reference. Please find and suggest me what could be the problem and how to solve it..

Thank you.
Attached Files
File Type: txt warnings.txt (605 Bytes, 0 views)
bioramg is offline   Reply With Quote