View Single Post
Old 06-15-2011, 07:08 AM   #1
bsk8635
Junior Member
 
Location: Kansas

Join Date: Jun 2011
Posts: 2
Post BFAST error during match: Could not start thread

Hi,

I have been playing around with BFAST the last couple of days and I can't get past the match step as it gives me the following error message after it has checked my command line arguments:


$ bfast match -f MgIM62u.fasta -r A1.fastq > bfast.matches.MgIM62u.bmf
************************************************************
Checking input parameters supplied by the user ...
Validating fastaFileName MgIM62u.fasta.
Validating readsFileName A1.fastq.
Validating tmpDir path ./.
**** Input arguments look good!
************************************************************
************************************************************
Printing Program Parameters:
programMode: [ExecuteProgram]
fastaFileName: MgIM62u.fasta
mainIndexes [Auto-recognizing]
secondaryIndexes [Not Using]
readsFileName: A1.fastq
offsets: [Using All]
loadAllIndexes: [Not Using]
compression: [Not Using]
space: [NT Space]
startReadNum: 1
endReadNum: 2147483647
keySize: [Not Using]
maxKeyMatches: 8
maxNumMatches: 384
whichStrand: [Both Strands]
numThreads: 1
queueLength: 250000
tmpDir: ./
timing: [Not Using]
************************************************************
Searching for main indexes...
Found 1 index (1 file).
Not using secondary indexes.
************************************************************
Reading in reference genome from MgIM62u.fasta.nt.brg.
In total read 1546 contigs for a total of 313500235 bases
************************************************************
Reading A1.fastq into a temp file.
Will process 30325510 reads.
************************************************************
Searching index file 1/1 (index #1, bin #1)...
Reading index from MgIM62u.fasta.nt.1.1.bif.
Read index from MgIM62u.fasta.nt.1.1.bif.
Reads processed: 0************************************************************
In function "FindMatches": Fatal Error[ThreadError]. Variable/Value: pthread_create: errCode.
Message: Could not start thread.
***** Exiting due to errors *****
************************************************************


Any ideas what this is related to? Since I have no idea what the problem is related to, I don't really know what additional information I should provide to help you help me.

Thanks in advance for your help!

-Boryana

Last edited by bsk8635; 06-15-2011 at 09:18 AM.
bsk8635 is offline   Reply With Quote