View Single Post
Old 12-02-2019, 01:47 AM   #1
Junior Member
Location: Sweden

Join Date: Nov 2019
Posts: 1
Default Tophat-fusion: Joining segment hits - FAILED


I have been aligning RNAseq data using tophat-fusion for downstream analysis of circularRNA using CIRCexplorer2 (requires tophat-fusion and bowtie1)

After trying many different configurations I have been successfully running alignment on 19/20 paired-end samples using: tophat v2.0.9, samtools v0.1.19, and bowtie v1.1.2 with the following command line:

tophat -o output -p 8 --fusion-search --keep-fasta-order --bowtie1 --no-coverage-search --fusion-min-dist 200 th_bowtie1_index/genome R1.fastq R2.fastq

With one sample though I am getting the following error in tophat.log:

Joining segment hits
Error running 'long_spanning_reads': what(): basic_string::substr

And the below error in long_spanning_reads.segs.log:

Loading fusions...done
terminate called after throwing an instance of 'std::out_of_range'
what(): basic_string::substr

(Full log files attached)

I canít seem to find any solution online except to change from bowtie1 to bowtie2 or re-download the index but the same settings/index files have been working with 19/20 other samples so I canít imagine there is an issue with the index or running bowtie1 and I want to run the alignment consistently for all samples i.e. with the same index and bowtie version.

I have also tried reducing the allocated memory but the same error is given.

If you have any suggestions on how to fix this it would be greatly appreciated!
Thanks very much in advance for you help with this!!
Attached Files
File Type: txt tophat.log.txt (3.3 KB, 1 views)
File Type: txt long_spanning_reads.segs.log.txt (512 Bytes, 0 views)
michew is offline   Reply With Quote