View Single Post
Old 02-26-2013, 09:38 AM   #1
rnavon
Junior Member
 
Location: Israel

Join Date: Feb 2013
Posts: 6
Default Tophat2 can't find Bowtie2

Hi Everyone,

After my previous installed tophat/bowtie versions worked without a problem, I wanted to update to the newest versions and also installed tophat2 and bowtie2. Both programs have links to them from the /bin directory which is in the path.
When trying to run the running example, tophat2 claims I do not have the correct version of bowtie installed. I'm a UNIX newbie and would appreciate any help and ideas!

Thanks!

Code:
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ bowtie --version
bowtie version 0.12.5
64-bit
Built on sycamore.umiacs.umd.edu
Sat Apr 24 15:56:29 EDT 2010
Compiler: gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)
Options: -O3 -m64  -Wl,--hash-style=both
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ bowtie2 --version
/bin/bowtie2-align version 2.1.0
64-bit
Built on igm3
Thu Feb 21 09:33:38 EST 2013
Compiler: gcc version 4.5.4 (GCC) 
Options: -O3 -m64 -msse2 -funroll-loops -g3 
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ tophat2 --version
TopHat v2.0.7
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ 
[galaxy01@gene3 test_data]$ tophat2 test_ref reads_1.fq reads_2.fq

[2013-02-26 09:35:20] Beginning TopHat run (v2.0.7)
-----------------------------------------------
[2013-02-26 09:35:20] Checking for Bowtie
Error: TopHat requires Bowtie 2.0.5 or later
[galaxy01@gene3 test_data]$
rnavon is offline   Reply With Quote