View Single Post
Old 06-07-2017, 10:01 AM   #6
alec
Member
 
Location: Cambridge, MA

Join Date: Apr 2011
Posts: 18
Default

Removing "/usr/lib/python3.4/:/usr/local/lib/python3.4/dist-packages" from the start of your PYTHONPATH should fix your immediate problem.

The problem is that bowtie2-build is using python 2.7 (because the first line is #!/usr/bin/env python). However, your PYTHONPATH is causing it to try to load python 3 libraries.

Alternatively, you could make sure that the location of python 3 is on your PATH variable. I'm not sure why `/usr/bin/env python` is launching 2.7 while in your earlier post you indicated that just typing `python` launches 3.4
alec is offline   Reply With Quote