View Single Post
Old 03-01-2011, 02:34 PM   #1
superligang
Member
 
Location: Los Angeles

Join Date: Mar 2010
Posts: 12
Default Is it normal for cufflinks produce different results in multiple run

I have running cufflink on 0.9M paired end sam data of human RNA and gtf annotations.

The GTF annotations were constructed based on the Ensembl, UCSC gene and refseq dataset downloaded from UCSD genome browser. There are 2.0M lines in the resulted GTF file.

I didn't generate the read alignments from tophat. Rather, I used blat and bowtie to align and pair the reads, and inferred the XS:A field from the gene annotations and the splicing signals for all the reads. I also included the SQ header in the result.

The way I ran cufflink is
cufflinks-0.9.3.Linux_x86_64/cufflinks --num-importance-samples 2000 --max-mle-iterations 10000 -v -G transcript.gtf -r hg19/all.chr.fa -N -o chrX chrX.sam.true.sort

Strangely, I ran cufflink multiple times on the same single chr sam data, and the estimated FPKM of some isoforms could be quite different. I observed for some genes, the ITERMAXs were not big enough for convergence, and so I increased the corresponding parameters, but the results still varied a lot.

I understand the MCMC in cufflink is a random process which may have different results depending on the initial state. Somehow I get the feeling that the latest version of cufflink stabilizes its result somehow, and so I wonder whether there is anything wrong about the way I prepared the dataset and ran cufflink?

Thank you very much
superligang is offline   Reply With Quote