View Single Post
Old 09-30-2010, 09:56 PM   #1
tguo
Junior Member
 
Location: maryland

Join Date: Sep 2010
Posts: 5
Default cufflinks - having difficulty reading reference GTF

Hi all,

I'm using cufflinks 0.9.0 beta. But the problem persists when I use v0.8.4.

Everything seems to work fine if I don't use a reference GTF.
But when I do use a reference (downloaded from the Ensembl FTP "current GTF" folder, Mouse release 59), cuffcompare doesn't seem to read from it.
(I did manually delete the giant transcript ENSMUST00000127664 from the GTF file to preclude the error message.)

When I run:
cuffcompare -r ../Mus_musculus.NCBIM37.56.gtf A.gtf B.gtf
where A.gtf and B.gtf are the two "transcripts.gtf" generated by cufflinks

the resulting "combined.gtf" file from cuffcompare does not contain any gene ID or gene name from the mouse reference GTF, and the refmap file is completely empty, too, besides the header row.

Does anyone have any idea what is going on?

Another weird thing is, if I run cufflinks with
"cufflinks -G ../Mus_musculus.NCBIM37.56.gtf A.sam",
then cufflinks does read the reference GTF, but in the output "transcripts.gtf", the estimated transcript levels are 0 for all transcripts...
However, if I run cufflinks without "-G", then the level estimation is correct.

Any ideas or help are highly appreciated!

TG

Last edited by tguo; 09-30-2010 at 10:03 PM.
tguo is offline   Reply With Quote