View Single Post
Old 06-01-2016, 05:10 AM   #1
clarissaboschi
Member
 
Location: US

Join Date: Apr 2010
Posts: 63
Default QTL overlap (bedtools)

Dear all, I am trying to compare some QTL regions with specific genome regions that I have, for it I am using bedtools.
I used before bedtools with a list of genes and it worked well, but this time I am getting the error message: "***** ERROR: too many digits/characters for integer conversion in string . Exiting...".

My input files are:
QTL file (with about 5,000 regions):
Chr1 241009 241109 GROW
Chr1 241009 241109 PLASCO
Chr1 2095900 3104645 BW
Chr1 2329958 2400142 AF
Chr1 2329958 2400142 BW


and my genomic regions input (with about 700 regions):
Chr1 18340001 18360000
Chr1 18350001 18370000
Chr1 18570001 18590000
Chr1 18960001 18980000
Chr1 18970001 18990000
Chr1 18980001 19000000

I tried different command lines, and I got the same error every time (and some times I had a output until the chromosome 8, and sometimes no result):
Code:
intersectBed -c -a QTLfile.bed  -b regionFile.bed > outfile
I am not sure what is the problem, I checked my files and it seems that they are ok....I tried also to increase the memory and split the chromosomes, and I also had the same error..

thanks

Last edited by clarissaboschi; 06-01-2016 at 12:27 PM.
clarissaboschi is offline   Reply With Quote