Thread: DESeq problems
View Single Post
Old 10-07-2011, 07:41 AM   #6
byou678
Member
 
Location: Maryland

Join Date: Aug 2011
Posts: 52
Smile

I had the similar problems as you and figured it out by using the old version manual (2010-01-19) with R2.11.1. Forget the "normalized" and " estimateDispersions" now Maybe somebody can use both to get the correct results (I cannot). And it will be great if s/he can share her/his details/experience with using "normalized" and " estimateDispersions" .

In addition, I am using R2.13.2 and cannot even successfully install the latest DESeq, Could anybody give my some ideas? Thanks.

> library("DESeq")
Loading required package: Biobase

Welcome to Bioconductor

Vignettes contain introductory material. To view, type
'browseVignettes()'. To cite Bioconductor, see
'citation("Biobase")' and for packages 'citation("pkgname")'.

Loading required package: locfit
Loading required package: akima
locfit 1.5-6 2010-01-20
Error in library.dynam(lib, package, package.lib) :
DLL 'genefilter' not found: maybe not installed for this architecture?
In addition: Warning messages:
1: '.readRDS' is deprecated.
Use 'readRDS' instead.
See help("Deprecated")
2: '.readRDS' is deprecated.
Use 'readRDS' instead.
See help("Deprecated")
Error: package/namespace load failed for 'DESeq'

Quote:
Originally Posted by janec View Post
I'm running DESeq for the first time and am having a few problems. I'm working through the documentation dated August 11, 2011.

I had no problems setting up a CountDataSet object with my counts table and can access the counts and estimate size factors for samples fine.

However when I tried to call the normalised counts, using the "normalized = TRUE" argument for the counts accessor, it says that there's no argument with that name. When I look at the man page for "counts", it also appears to have no arguments other than the name of the object it is counting.

I skipped that step and went on to the variance estimation stage, but when I try to run the estimateDispersions function I get a "function not found" message.

Is there something else I need to have installed?

Cheers!

Last edited by byou678; 10-07-2011 at 07:45 AM.
byou678 is offline   Reply With Quote