View Single Post
Old 08-02-2016, 03:13 AM   #2
asier_gonzalez
Junior Member
 
Location: Harpenden

Join Date: Dec 2015
Posts: 7
Default

Hi dovah,

Cufflinks requires the input alignments to be sorted by chromosomal position and that is what the sort command you posted is doing.

You can use samtools sort using the default parameters (not -n as sorts by read name) and you will achieve the same results which should work with cufflinks. Why do you say this doesn't work?

Let me ask a few more questions:
* Which organism are you working with?
* How big are the sam files you are working with?
* How much RAM has the server you are using?

Also keep in mind that HISAT requires the option "--dta-cufflinks" so that it reports the output SAM with the attributes needed by cufflinks.

Cheers,

Asier
asier_gonzalez is offline   Reply With Quote