View Single Post
Old 09-28-2011, 08:59 AM   #2
fkrueger
Senior Member
 
Location: Cambridge, UK

Join Date: Sep 2009
Posts: 611
Default

There seem to be quite a few things going wrong here. From the error message "Error: reads file does not look like a FASTA file" you can see that Bowtie expects Fasta sequences, and not FastQ. My guess is that the switch "-ff" does that. Did you mean to use "--ff"?

A few other things:
-q is default already, no need to specify
-n expects a value between 0 and 3, default is 2
-r and --solexa1.3-quals are conflicting. Your reads are not in Raw format, so simply use --solexa1.3-quals
-I 0 is default so not needed
-X 100 seems to be a very low value, what was the read length in your experiment?
- Did you really mean to use the --ff option?
From the Bowtie manual:
--ff The upstream/downstream mate orientations for a valid paired-end alignment against the forward reference strand. E.g., if --fr is specified and there is a candidate paired-end alignment where mate1 appears upstream of the reverse complement of mate2 and the insert length constraints are met, that alignment is valid. Also, if mate2 appears upstream of the reverse complement of mate1 and all other constraints are met, that too is valid. --rf likewise requires that an upstream mate1 be reverse-complemented and a downstream mate2 be forward-oriented. --ff requires both an upstream mate1 and a downstream mate2 to be forward-oriented. Default: --fr when -C (colorspace alignment) is not specified, --ff when -C is specified.

-Bowtie does not read input in .gz format (at least not yet)
And as a final remark, if you want to align mRNA reads you might want to use an aligner which can cope with exon-spanning reads, such as TopHat.

Hope this helps.
fkrueger is offline   Reply With Quote