View Single Post
Old 09-28-2011, 12:15 PM   #4
fkrueger
Senior Member
 
Location: Cambridge, UK

Join Date: Sep 2009
Posts: 610
Default

This is much better aleady, this time Bowtie doesn't die but merely produces warnings. You can avoid these by giving it more memory for each alignment with the --chunkmbs option. Try --chunkmbs 512 to start with, this normally fixes everything (consult the Bowtie manual for more info on this parameter).

Other than that:
-n 2 is not needed as it is the default
-X 100: I still think this is likely not what you meant.

From the Bowtie Manual:
-X/--maxins <int>
The maximum insert size for valid paired-end alignments. E.g. if -X 100 is specified and a paired-end alignment consists of two 20-bp alignments in the proper orientation with a 60-bp gap between them, that alignment is considered valid (as long as -I is also satisfied). A 61-bp gap would not be valid in that case. If trimming options -3 or -5 are also used, the -X constraint is applied with respect to the untrimmed mates, not the trimmed mates. Default: 250.

If you specify -X 100 at a read length of 90bp then you will only get reads which overlap over nearly the entire length. Remember length(read1)+lenght(insert)+length(read2) need to be smaller than X in order to yield a valid alignment. So in your case something like 400-600 would seem more realistic.

Good luck (and still think about using a splice mapper instead)!
fkrueger is offline   Reply With Quote