View Single Post
Old 04-30-2014, 06:19 AM   #1
sfh838t
Member
 
Location: Mountain Grove, MO, USA

Join Date: Apr 2014
Posts: 29
Default velvet columbus reference errors

I have seen some posts about using velvet with a reference, but they have not helped me........
I am trying to assemble a plant genome using a related species as reference. Trying to use velvet columbus, but I don't seem to be able to get the command line right.
following the manual, using:
velveth dir_name 31 -reference ref.fasta -sam illumina_align.sam
this way I get: -sam file cannot contain reference sequence.
if I try to add -short or -long in front of the -sam switch, it seems to ignore the -reference switch and I get that my "read1" (which is supposed to be the reference) is too long.
I have removed from the sam file anything that might have something to do with the reference, but still get the same error.
I am not good with the linux command line and I am getting the impression i am forgetting some little space, comma, slash or something.
I used bowtie2 for the alignment of the single end read Illumina reads. Does someone know if bowtie puts the reference sequence into it's sam output anywhere? Or, since all the posts about velvet columbus I have been able to find deal with PE input, can velvet with reference only be used with PE reads?
sfh838t is offline   Reply With Quote