View Single Post
Old 04-28-2015, 06:55 AM   #1
jov14
Member
 
Location: Germany

Join Date: Oct 2014
Posts: 16
Default problems configuring installation of Bcl2fastq

Hi,
I want to install Bcl2fastq on my system running Ubuntu 14.04.2 LTS. I have admin rights.

However the configure step always aborts with an error.

After running configure I first ran into the typical Error messages of "No support for gzip compression" and "No support for bzip2 compression", so i followed early recommendations here and here, and copied "libz.so", "libpthread*" and "libbz2.so" from /usr/lib/x86_64-linux-gnu/ to /usr/lib.

after that, running "configure" produced this new error message:
Code:
CMake Error at cmake/cxxConfigure.cmake:95 (message):
  libxml2 was not found
As this problem has not been discussed earlier, I tried to use the same approach by copying the libxml2-associated files to /user/lib using the following command:
Code:
sudo cp /usr/lib/x86_64-linux-gnu/libxml2* /usr/local/lib
As this did not help I followed the setup instruction at the end of this thread and this very helpful setup-script to ensure that all dependancies are met.

However I still get the same error message:
Code:
-- Could NOT find LibXml2 (missing:  LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR) 
CMake Error at cmake/cxxConfigure.cmake:95 (message):
  libxml2 was not found
Call Stack (most recent call first):
  c++/CMakeLists.txt:33 (include)


-- Configuring incomplete, errors occurred!
Couldn't configure the project:

/tmp/bcl2fastq-build/bootstrap/bin/cmake -H"/tmp/bcl2fastq/src" -B"/tmp/bcl2fastq-build" -G"Unix Makefiles"  -DCASAVA_PREFIX:PATH=/usr/local/tools/bcl2fastq-1.8.4 -DCASAVA_EXEC_PREFIX:PATH= -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/tools/bcl2fastq-1.8.4 -DCASAVA_BINDIR:PATH= -DCASAVA_LIBDIR:PATH= -DCASAVA_LIBEXECDIR:PATH= -DCASAVA_INCLUDEDIR:PATH= -DCASAVA_DATADIR:PATH= -DCASAVA_DOCDIR:PATH= -DCASAVA_MANDIR:PATH= -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo

Moving CMakeCache.txt to CMakeCache.txt.removed
Any suggestions?
jov14 is offline   Reply With Quote