View Single Post
Old 06-03-2014, 05:01 AM   #57
WhatsOEver
Senior Member
 
Location: Germany

Join Date: Apr 2012
Posts: 215
Default

Dear Brian,

I'm coming with another problem (bug?), I cannot find an answer to. I run a RNAseq mapping with bbmap and got afterwards the following results:

Quote:
Genome: 1
Key Length: 14
Max Indel: 200000
Minimum Score Ratio: 0.4
Mapping Mode: normal
Reads Used: 702748 (302588801 bases)

Mapping: 2780.014 seconds.
Reads/sec: 252.79
kBases/sec: 108.84


Read 1 data: pct reads num reads pct bases num bases

mapped: 98.1544% 689778 98.8899% 299229721
unambiguous: 96.8285% 680460 97.9391% 296352687
ambiguous: 1.3259% 9318 0.9508% 2877034
low-Q discards: 0.0011% 8 0.0001% 185

...
As I don't like the samtools flagstat output, I wrote my own samfile-parser in order to compare the output of different mappers and different parameters used for mapping. From the samfile that was produced by bbmap, my parser returned the following

Quote:
Found 762672 entries in the samfile.
Identified 702748 different reads.
663897 of the reads have unique mapping positions.
25881 of the reads have 85805 ambiguous mapping positions.
12970 of the reads did not map to the reference.
Elapsed seconds: 4
I verified these results by counting the individual bit-flags.
As this is quite different to your program output (except for the unmapped reads), I'm wondering were the mistake is?

Cheers,
W

Last edited by WhatsOEver; 06-03-2014 at 06:03 AM.
WhatsOEver is offline   Reply With Quote