SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics

Similar Threads
Thread Thread Starter Forum Replies Last Post
samtool sort: truncated file error? shawpa Bioinformatics 0 12-29-2011 12:21 PM
Truncated BAM files from 1000GP gene coder Bioinformatics 4 07-15-2011 11:02 AM
Truncated TopHat Files jrober04 Bioinformatics 9 06-30-2011 01:57 AM
help on "truncated file", when converting sam to bam jianfeng.mao Bioinformatics 0 12-18-2010 03:03 AM
truncated adapter sequences in cloned libraries greigite Illumina/Solexa 0 11-08-2010 01:43 PM

Reply
 
Thread Tools
Old 11-15-2011, 10:09 AM   #1
lbthrice
Junior Member
 
Location: New Hampshire

Join Date: Dec 2010
Posts: 4
Default mpileup: specified region truncated.

Hello gentlepeople,

I am using the samtools 'mpileup' program.
I wish to generate a pileup file for a specific region.
I have several separate .bam input files that I am generating the pileups for.
Unfortunately, mpileup truncates the region and I only get data for the first part of the region.
I have ran the same command on different .bam files and get different results.

When I command:

samtools mpileup -f 'hg19.fa' -r chr6:27114408-27115845 'experiment01.bam' > out_PILEUP2.pile
[mpileup] 1 samples in 1 input files
<mpileup> Set max per-file depth to 8000

I get a file with 746 lines.
I am expecting 1438 lines because that is the size of the interval I have specified with the '-r' flag
If I use mpileup with the same region but with a different .bam file I get a different size file.

samtools mpileup -f 'hg19.fa' -r chr6:27114408-27115845 'experiment02.bam' > out_PILEUP3.pile
[mpileup] 1 samples in 1 input files
<mpileup> Set max per-file depth to 8000

I get a file with 623 lines.
Again, I am expecting 1438 lines because that is the size of the interval I have specified with the '-r' flag.

The first line in both files is for chr6:27114408, as expected.
BUT, the files are truncated at different positions.
With experiment01.bam the final line of the pileup file is chr6:27115577.
With experiment02.bam the final line of the pileup file is chr6:27115344.

This must have something to do with the .bam file.
Can someone tell me which parameter needs to be adjusted?
I have consulted the manual but I could not identify anything that sounded applicable.

Thanks for you time,
Lionel (Lee) Brooks 3rd
Dartmouth Genetics Grad Student
lbthrice is offline   Reply With Quote
Old 11-15-2011, 12:01 PM   #2
swbarnes2
Senior Member
 
Location: San Diego

Join Date: May 2008
Posts: 901
Default

The simplest answer is that you just don't have any reads across part of your region.

Try getting the .sam file for the same region +- 500 bases, or try looking at the whole .bam in IGV. You can zoom in on your region.
swbarnes2 is offline   Reply With Quote
Old 11-15-2011, 12:12 PM   #3
gringer
David Eccles (gringer)
 
Location: Wellington, New Zealand

Join Date: May 2011
Posts: 552
Default

Yeah, mpileup doesn't generate lines for regions it has no reads on. If you need to work out whole-region coverage, then you should be looking at the column that gives the base number. For covered regions, this will increase by 1 per line (assuming no inserts), but will jump multiple bases when there are no reads.
gringer is offline   Reply With Quote
Old 11-15-2011, 01:59 PM   #4
lbthrice
Junior Member
 
Location: New Hampshire

Join Date: Dec 2010
Posts: 4
Default

whoops, should have checked that...thanks!
lbthrice is offline   Reply With Quote
Reply

Tags
mpileup, pileup, samtools

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.