SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
cummeRbund installation m_elena_bioinfo Bioinformatics 3 08-02-2012 01:42 AM
Experiment deletion failing BenjaminL Ion Torrent 0 07-29-2012 10:10 PM
BWA and Samtools installation failing JamesT Bioinformatics 3 07-02-2012 03:24 AM
Tophat problem: failing reads alignment Annibal RNA Sequencing 6 05-18-2012 12:34 PM
TopHat 1.1 failing on colorspace SE reads krobison Bioinformatics 22 09-22-2011 11:25 AM

Reply
 
Thread Tools
Old 02-25-2013, 12:00 PM   #21
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default Error in library(cummeRbund) : there is no package called ‘cummeRbund

duplicated posting

Last edited by myRNA_Seq; 02-25-2013 at 12:08 PM. Reason: duplicated
myRNA_Seq is offline   Reply With Quote
Old 02-25-2013, 12:04 PM   #22
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default > library(cummeRbund) Error in library(cummeRbund) : there is no package called ‘cumm

I also tried the following as GenoMax suggested to cnyh:

[email protected]:/$ sudo apt-get install libxml2 libcurl
[sudo] password for liuzi:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libcurl
myRNA_Seq is offline   Reply With Quote
Old 02-25-2013, 12:26 PM   #23
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

I also tried the following
sudo apt-get install libxml2-dev;
and still get the same error message...
myRNA_Seq is offline   Reply With Quote
Old 02-25-2013, 12:34 PM   #24
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Quote:
Originally Posted by myRNA_Seq View Post
I also tried the following
sudo apt-get install libxml2-dev;
and still get the same error message...
I think you will need one of the dev packages for curl. Try this one

Code:
sudo apt-get install libcurl4-openssl-dev
GenoMax is online now   Reply With Quote
Old 02-25-2013, 12:55 PM   #25
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

Thank you,GenoMax for your quick reply.

I installed "sudo apt-get install libcurl4-openssl-dev" as you suggested.
I still get the same error below.

> library(cummeRbund)
Error in library(cummeRbund) : there is no package called ‘cummeRbund’
myRNA_Seq is offline   Reply With Quote
Old 02-26-2013, 02:58 AM   #26
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Quote:
Originally Posted by myRNA_Seq View Post
Thank you,GenoMax for your quick reply.

I installed "sudo apt-get install libcurl4-openssl-dev" as you suggested.
I still get the same error below.

> library(cummeRbund)
Error in library(cummeRbund) : there is no package called ‘cummeRbund’
Did you try to re-install cummeRbund in R after installing the curl library?

Code:
> source("http://bioconductor.org/biocLite.R")
> biocLite("cummeRbund")
GenoMax is online now   Reply With Quote
Old 02-26-2013, 04:47 AM   #27
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Smile

Thank you so much GenoMax!
Following your instruction, I re-installed cummeRbund in R, now it works very well.
myRNA_Seq is offline   Reply With Quote
Old 02-27-2013, 05:39 AM   #28
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

I have another problem now.

I downloaded latest version of cufflinks binary and also added them to my path as following:
export PATH=$PATH:~/cufflinks-2.0.2.Linux_x86_64/cufflinks
export PATH=$PATH:~/cufflinks-2.0.2.Linux_x86_64/cuffdiff
export PATH=$PATH:~/cufflinks-2.0.2.Linux_x86_64/cuffcompare

When I tried to run cuffcompare, it gave me a warning:

Warning: Your version of Cufflinks is not up-to-date. It is recommended that you upgrade to Cufflinks v2.0.2 to benefit from the most recent features and bug fixes (http://cufflinks.cbcb.umd.edu).

and without *.tmap file generated.

So far I have checked, there isn't a copy of cufflinks in other PATHs, such as .: /usr/bin /usr/local/bin etc...

Is there any problem in terms of the path setting?

Thanks a lot

Last edited by myRNA_Seq; 02-27-2013 at 05:41 AM.
myRNA_Seq is offline   Reply With Quote
Old 02-27-2013, 07:44 AM   #29
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Quote:
Originally Posted by myRNA_Seq View Post
I have another problem now.


So far I have checked, there isn't a copy of cufflinks in other PATHs, such as .: /usr/bin /usr/local/bin etc...

Is there any problem in terms of the path setting?

Thanks a lot
Can you check the following and verify that you are indeed pointing to the right cufflinks executable?

Code:
$which cufflinks
GenoMax is online now   Reply With Quote
Old 02-27-2013, 07:49 AM   #30
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

It says: /usr/bin/cufflinks.
When I use echo $PATH, it didn't show there, why?

************
I have tried full path. It works without warning anymore, and got all the output files except *.refmap *.tmap file. Do you know why?

I followed the instruction from the paper "Differential gene and transcript expression analysis of RNA-seq experiments with TopHat and Cufflinks" (http://www.nature.com/nprot/journal/....2012.016.html) and use exact files in the examples.

$ find . -name transcripts.gtf > gtf_out_list.txt
$ ~/cufflinks-2.0.2.Linux_x86_64/cuffcompare - i gtf_out_list.txt -r gene.gtf
myRNA_Seq is offline   Reply With Quote
Old 02-27-2013, 08:54 AM   #31
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Quote:
Originally Posted by myRNA_Seq View Post
It says: /usr/bin/cufflinks.
When I use echo $PATH, it didn't show there, why?
You may actually have an older "cufflinks" in /usr/bin (do a long listing
Code:
ls -l /usr/bin
to see if that it true) or there may be a softlink to some other cufflinks somewhere else on the system (if this is a shared server then that is a possibility).

echo $PATH will only show directories included in your PATH variable (not the specific programs).

Quote:
Originally Posted by myRNA_Seq View Post
************

I followed the instruction from the paper "Differential gene and transcript expression analysis of RNA-seq experiments with TopHat and Cufflinks" (http://www.nature.com/nprot/journal/....2012.016.html) and use exact files in the examples.

$ find . -name transcripts.gtf > gtf_out_list.txt
$ ~/cufflinks-2.0.2.Linux_x86_64/cuffcompare - i gtf_out_list.txt -r gene.gtf
Is the "gtf_out_list.txt" file successfully created? Make sure it is a non-zero byte file (i.e. there is something in it, by using cat/more commands to look at the file contents).
GenoMax is online now   Reply With Quote
Old 02-27-2013, 09:26 AM   #32
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

Yes. I found cufflinks (cuffcompare; cuffmerge; cuffdiff...) using code: ls -l /usr/bin.

How can I remove them or how can I get the path that I set as the priority.
The file "gtf_out_list.txt" was successfully created.

Using full path, it works without warning anymore, and got all the output files except *.refmap *.tmap file. Do you know why? I need use these files for next step.
myRNA_Seq is offline   Reply With Quote
Old 02-27-2013, 10:12 AM   #33
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Quote:
Originally Posted by myRNA_Seq View Post
Yes. I found cufflinks (cuffcompare; cuffmerge; cuffdiff...) using code: ls -l /usr/bin.

How can I remove them or how can I get the path that I set as the priority.
Amend your PATH variable (pre-pathing) like this in a new shell. This should make the system look at your local directories first before going to /usr/bin.

Code:
export PATH=~/cufflinks-2.0.2.Linux_x86_64/cufflinks:~/cufflinks-2.0.2.Linux_x86_64/cuffdiff:~/cufflinks-2.0.2.Linux_x86_64/cuffcompare:$PATH
If you are the administrator of this system you could rename the older versions (is that the case?) in /usr/bin with some extension (e.g. /usr/bin/cuffcompare to /use/bin/cuffcompare_OLD) and then try the run again.


Quote:
Originally Posted by myRNA_Seq View Post

The file "gtf_out_list.txt" was successfully created.

Using full path, it works without warning anymore, and got all the output files except *.refmap *.tmap file. Do you know why? I need use these files for next step.
If the files are not being generated then there must be some error that is occurring. You can try to capture that error by running your cuffcompare command this way (which will capture the stderr messages to a file)
Code:
$cuffcompare -i gtf_out_list.txt -r genes.gtf 2> cuffcompare_errors.txt
GenoMax is online now   Reply With Quote
Old 02-27-2013, 10:17 AM   #34
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

With this commend, still no error is reported, the output content are the following:

you are using cufflinks v2.0.2, which is the most recent release.
myRNA_Seq is offline   Reply With Quote
Old 02-28-2013, 11:56 AM   #35
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

Since the original protocol was written for older versions of TopHat and Bowtie I am running it now to see if it can be completed successfully with the newest versions available now.
GenoMax is online now   Reply With Quote
Old 03-01-2013, 05:44 AM   #36
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Default

Thank you so much, GenoMax. The data I used were the simulatedFastq_Files (from GSM794488).
myRNA_Seq is offline   Reply With Quote
Old 03-01-2013, 09:54 AM   #37
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,748
Default

The workflow described in nature protocols papers did work for me with the newest versions of TopHat (2.0.8), Cufflinks (2.0.2) and Bowtie2 (2.1.0). I also used the simulated data set.

Perhaps your cuffcompare did not work correctly if you are not seeing the *.tmap files.

Note: I did not check the R related parts from the protocol.

Last edited by GenoMax; 03-01-2013 at 11:19 AM. Reason: additional clarification
GenoMax is online now   Reply With Quote
Old 03-01-2013, 11:13 AM   #38
nprash
Junior Member
 
Location: USA

Join Date: Mar 2013
Posts: 4
Unhappy cummeRbund problems with functions

I was able to successfully use readCufflinks after installed cummerbund but that's how far I could go with it. None of the functions seemed to work as expected. Here's the disastrous session info:
> library(cummeRbund)
Loading required package: RSQLite
Loading required package: DBI
Loading required package: reshape
Loading required package: plyr

Attaching package: ‘reshape’

The following object(s) are masked from ‘packagelyr’:

rename, round_any

Loading required package: ggplot2
> cuff<-readCufflinks('diff_out_2252013-1')
Creating database diff_out_2252013-1/cuffData.db
Reading diff_out_2252013-1/genes.fpkm_tracking
Checking samples table...
Populating samples table...
Writing genes table
Reshaping geneData table
Recasting
Writing geneData table
Reading diff_out_2252013-1/gene_exp.diff
Writing geneExpDiffData table
Reading diff_out_2252013-1/promoters.diff
Writing promoterDiffData table
Reading diff_out_2252013-1/isoforms.fpkm_tracking
Checking samples table...
OK!
Writing isoforms table
Reshaping isoformData table
Recasting
Writing isoformData table
Reading diff_out_2252013-1/isoform_exp.diff
Writing isoformExpDiffData table
Reading diff_out_2252013-1/tss_groups.fpkm_tracking
Checking samples table...
OK!
Writing TSS table
Reshaping TSSData table
Recasting
Writing TSSData table
Reading diff_out_2252013-1/tss_group_exp.diff
Writing TSSExpDiffData table
Reading diff_out_2252013-1/splicing.diff
Writing splicingDiffData table
Reading diff_out_2252013-1/cds.fpkm_tracking
Checking samples table...
OK!
Writing CDS table
Reshaping CDSData table
Recasting
Writing CDSData table
Reading diff_out_2252013-1/cds_exp.diff
Writing CDSExpDiffData table
Reading diff_out_2252013-1/cds.diff
Writing CDSDiffData table
Indexing Tables...
> csDensity(genes(cuff))
'opts' is deprecated. Use 'theme' instead. (Deprecated; last used in version 0.9.1)
Setting the plot title with opts(title="...") is deprecated.
Use labs(title="...") or ggtitle("...") instead. (Deprecated; last used in version 0.9.1)
> diffGeneIDs <- getSig(cuff,level="genes",alpha=0.05)
Error: could not find function "getSig"

Please help!
nprash is offline   Reply With Quote
Old 03-01-2013, 12:02 PM   #39
myRNA_Seq
Member
 
Location: Canda

Join Date: Feb 2013
Posts: 18
Smile

Thank you very much GenoMax. It works for me too. I re-run some of the protocol to get the searchable index for each map files. it could be because of some of the program in wrong path and the old one was working there.
myRNA_Seq is offline   Reply With Quote
Old 04-18-2013, 02:59 PM   #40
mbzmg1
Junior Member
 
Location: Colorado

Join Date: Feb 2012
Posts: 9
Default

I was getting the same error on Ubuntu 12.04 and R 2.15.3:
installation of package ‘cummeRbund’ had non-zero exit status

and can confirm that running first:
sudo apt-get install libxml2-dev
sudo apt-get install libcurl4-openssl-dev

followed by:
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")

allows the installation to complete
mbzmg1 is offline   Reply With Quote
Reply

Tags
bioconductor, cummerbund, installation

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO