SEQanswers

Go Back   SEQanswers > General



Similar Threads
Thread Thread Starter Forum Replies Last Post
Old(?) bowtie file: "missing quality values" error in tophat worm_picker Bioinformatics 3 08-28-2014 03:01 PM
Samtools and bcftools: Why aren't some of the calls "missing data". molecules Bioinformatics 0 01-10-2014 11:07 AM
[EdgeR] exactTest dispersion="common" syintel87 Bioinformatics 0 05-23-2013 07:12 PM
BWA aligned sam file missing "QNAME" format silentio Bioinformatics 3 05-21-2013 08:19 PM
Error in GERALD - "Missing 'chromosome' element" Rachelly Illumina/Solexa 0 10-10-2010 06:47 AM

Reply
 
Thread Tools
Old 10-31-2016, 07:08 PM   #1
SuzuBell
Member
 
Location: Iowa

Join Date: Nov 2013
Posts: 11
Default argument "dispersion" is missing, with no default

Hi!

I am trying to perform DEG analysis on two treatment groups using edgeR. I originally planned to keep the analysis similar to what was used for another purpose previously. To prepare the data, I used the following functions/code:

Code:
    y <- DGEList(counts=countTable, group=listGroups)
    keep <- rowSums(cpm(y)>1) >= 2*nRep #Filtering rows
    y <- y[keep, keep.lib.sizes=FALSE] #Filtering rows
    y <- cpm(y, TRUE, TRUE) # Option 2 (edgeR)
    y <- betweenLaneNormalization(y, which="full", round=FALSE)
This seems to work fine, and leads to an object y with the following structure:

Code:
> head(y)
                                N.1      N.2      N.3      P.1      P.2      P.3
G1093 2.643383 2.624754 2.643383 2.800242 2.687257 2.258823
G3412 2.689673 3.302018 3.402223 4.290321 4.294549 4.354116
G4872 4.115490 4.412357 4.427337 4.526043 4.074346 4.037426
G2856 3.271944 2.946745 3.467242 2.643383 2.687257 3.043792
G3810 3.043792 3.501425 3.286707 3.547066 3.493566 3.429753
G4756 3.949146 3.653455 4.189536 4.132336 4.205552 4.074346
I planned on running the next sequence of edgeR functions as follows:

Code:
    y = estimateCommonDisp(y)
    y = estimateTagwiseDisp(y)
    de = exactTest(y, pair=c(group1,group2))
    tt = topTags(de, n=nrow(y))
    nc = cpm(y, normalized.lib.sizes=TRUE)
However, I receive an error upon running estimateTagwiseDisp() as follows:

Code:
Error in aveLogCPM.default(y, lib.size = lib.size, dispersion = dispersion) : 
  argument "dispersion" is missing, with no default
I am not too confident in what I have here. Everything before estimateCommonDisp() was intended to be consistent with previous work done on this data. However, I am concerned about what we may be missing here.

Any suggestions would be greatly appreciated!
SuzuBell is offline   Reply With Quote
Reply

Tags
edaseq, edger, error, estimatedipersions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO