SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Maq Segmentation fault Seq84 Bioinformatics 3 07-13-2012 04:05 AM
soap segmentation fault scami Bioinformatics 6 04-17-2012 06:08 AM
cufflinks segmentation fault help please seq_newbie Bioinformatics 1 06-29-2011 11:52 AM
Maq: Segmentation Fault mrxcm3 Bioinformatics 2 03-21-2011 02:43 PM
SOAP:segmentation fault Mansequencer Bioinformatics 1 11-19-2010 10:47 AM

Reply
 
Thread Tools
Old 04-29-2009, 07:44 AM   #1
dukevn
Member
 
Location: RI

Join Date: Apr 2009
Posts: 50
Default MAQ - Segmentation fault

Hi all,

I just started with the DNA sequencing and analysis area and everything is all new to me. So please be easy on me.

Now I am trying to learn how to align and analyze data. I downloaded MAQ, compiled it (in PowerPC G5 computer), copied maq, maq.pl etc to runfiles director, and try to run with a test data file as suggested in MAQ

Code:
maq.pl demo ref.fasta calib-36.dat
Calib-36.dat came together with the MAQ package, and ref.fasta is as simple as

Code:
>D86934(D86934)probable sugar-nucleotide dehydratase [imported] - Mycobacterium leprae
MYGEPVRALVTGAAGFIGSTLVDRLLADGHTVVGLDNFATGHAANLEHLASTPALAFVEA
DIVTADLQTILDEHRPEVVFHLAAQIDVRHSVVDPQFDASVNVIGTVRLAEAARHTGVRK
IVHTSSGGSIYGTPSQYPTPETVPTDPTSPYAAGKVAGEIYLNTFRHLCGLDCSHIAPAN
VYGPRQDPYGEAGVVAIFVQALLSDRPTKVFGDGTHTRDYVFVDDVVDAFIKASGDAGGG
QRFNIGTGIETSDRQLHTAVSAAVGGPDDPEFHPPRLGDLKRSCLDIGLATTVLGWSPQV
QLDDGVRRTVEYFRAAQRS
After a while, I got Segmentation fault error:

Code:
-- CMD: mkdir -p maqdemo
-- CMD: /usr/local/bin/maq simulate -N 1000000 maqdemo/r1.fq maqdemo/r2.fq ref.fasta calib-36.dat > maqdemo/true.snp
-- 1 sequences, total length: 319
sh: line 1: 37110 Segmentation fault      /usr/local/bin/maq simulate -N 1000000 maqdemo/r1.fq maqdemo/r2.fq ref.fasta calib-36.dat > maqdemo/true.snp
** fail to run command '/usr/local/bin/maq simulate -N 1000000 maqdemo/r1.fq maqdemo/r2.fq ref.fasta calib-36.dat > maqdemo/true.snp' at /usr/local/bin/maq.pl line 842.
What I am doing wrong, or is this any missing step that I forget? Anybody help please!

Last edited by dukevn; 04-29-2009 at 07:56 AM. Reason: fixed codes
dukevn is offline   Reply With Quote
Old 04-30-2009, 12:07 PM   #2
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by dukevn View Post
Hi all,

Code:
>D86934(D86934)probable sugar-nucleotide dehydratase [imported] - Mycobacterium leprae
MYGEPVRALVTGAAGFIGSTLVDRLLADGHTVVGLDNFATGHAANLEHLASTPALAFVEA
DIVTADLQTILDEHRPEVVFHLAAQIDVRHSVVDPQFDASVNVIGTVRLAEAARHTGVRK
IVHTSSGGSIYGTPSQYPTPETVPTDPTSPYAAGKVAGEIYLNTFRHLCGLDCSHIAPAN
VYGPRQDPYGEAGVVAIFVQALLSDRPTKVFGDGTHTRDYVFVDDVVDAFIKASGDAGGG
QRFNIGTGIETSDRQLHTAVSAAVGGPDDPEFHPPRLGDLKRSCLDIGLATTVLGWSPQV
QLDDGVRRTVEYFRAAQRS

That doesn't look any DNA I have seen before!
nilshomer is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO