SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in Galaxy tool execution? nilmot13 Bioinformatics 2 01-26-2012 03:34 AM
upload error in local instance of galaxy Ami Bioinformatics 2 10-19-2011 09:53 AM
Galaxy-filter pileup error rudi283 Bioinformatics 3 04-15-2011 03:44 AM
Galaxy tools - local installation doc.ramses Bioinformatics 0 01-12-2011 01:32 AM
galaxy command line error gfmgfm Bioinformatics 1 12-28-2010 11:38 PM

Reply
 
Thread Tools
Old 04-26-2011, 04:19 AM   #1
doc.ramses
Member
 
Location: Planet Earth

Join Date: Jan 2011
Posts: 26
Default galaxy tools and samtools error

Hi,

on a local installation of the latest "galaxy-tools" I mapped with "Bowtie for Illumina" and also performed "Filter SAM". It both worked well for the 22GB big fow and rev pe reads. When running "SAM-to-BAM" on the resulting 54GB file, I get the following error message:

An error occurred running this job: Samtools Version: 0.1.12a (r862)
python(4996,0x7fff70df9ca0) malloc: *** mmap(size=140735421464576) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
Error extracting alignments from

I assume it has something to do with the memory. Although I can't believe that this is a size problem, as I'm doing this on the latest 12core macpro with 16GB-RAM.

Another issue that I have in galaxy-tools is that I'm not able to save the filtered file (app. 50GB).

Thank you for your help!
doc.ramses is offline   Reply With Quote
Old 04-26-2011, 06:14 AM   #2
maubp
Peter (Biopython etc)
 
Location: Dundee, Scotland, UK

Join Date: Jul 2009
Posts: 1,543
Default

Quote:
Originally Posted by doc.ramses View Post
When running "SAM-to-BAM" on the resulting 54GB file, I get the following error message:

An error occurred running this job: Samtools Version: 0.1.12a (r862)
python(4996,0x7fff70df9ca0) malloc: *** mmap(size=140735421464576) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
Error extracting alignments from

I assume it has something to do with the memory. Although I can't believe that this is a size problem, as I'm doing this on the latest 12core macpro with 16GB-RAM.
I'm fairly sure that size in in bytes... and 140735421464576 bytes = 137436935024 KB = 134215756 MB = 131070 GB = 127 PB
(using 1024 rather than 1000 for pedants)

Which is lot more than 16GB which explains why malloc fails to allocate enough memory, but on the other hand 127 PB is so big that perhaps something had gone wrong before that?
maubp is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO