SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Newbler 2.5.3 on 64 bit Ubuntu...anyone??? WaltL 454 Pyrosequencing 30 10-31-2011 12:06 AM
Installing GS FLX v2.6 in Ubuntu? MissChristine Bioinformatics 2 07-20-2011 08:32 PM
Tabix Error on Ubuntu 10.04 JMFA Bioinformatics 2 11-25-2010 06:06 AM
Maq make error on Ubuntu 9.04 64 bit sbberes Bioinformatics 3 10-14-2009 08:36 AM
maq compile error on Ubuntu baozhi Bioinformatics 1 02-19-2009 02:28 PM

Reply
 
Thread Tools
Old 01-12-2010, 06:08 AM   #1
sanzi
Junior Member
 
Location: USA

Join Date: Jan 2010
Posts: 1
Post error when installing GAPipeline-1.5.0 in ubuntu amd64

I tried to install GAPipeline-1.5.0 in my desktop (64-bit linux Ubuntu 9.10). I have installed all prerequisites, and still got the following errors. Basically, the first error is "‘uint64_t’ was not declared in this scope" Does someone know how to fix it? Thanks.

The command I used is:
sudo make install WITH_IO_LIB=1

====== screen message ======
CPATH=: LIBRARY_PATH=: ./validate.sh --prereqs
Checking for prerequisites
Prerequisites OK (no further validation requested)
make --directory opt cmake
make[1]: Entering directory `/share/apps/GAPipeline/opt'
PATH=/share/apps/GAPipeline/opt/bin:$PATH bootstrap/bootstrap.sh cmake
cmake version "cmake version 2.6-patch 2" is already installed
nothing to be done
make[1]: Leaving directory `/share/apps/GAPipeline/opt'
cd build && PATH=/share/apps/GAPipeline/opt/bin:$PATH LIB=: cmake ..
-- Found PTHREAD header: /usr/include/pthread.h
-- Found PTHREAD library: /usr/lib/libpthread.so
-- Found ZLIB header: /usr/include/zlib.h
-- Found ZLIB library: /usr/lib/libz.so
-- gzip compression supported
-- Found BZIP2 header: /usr/include/bzlib.h
-- Found BZIP2 library: /usr/lib/libbz2.so
-- bzip2 compression supported
-- Found FFTW3F header: /usr/include/fftw3.h
-- Found FFTW3F library: /usr/lib/libfftw3f.so
-- Using FFTW header: /usr/include/fftw3.h
-- Using FFTW library: /usr/lib/libfftw3f.so
-- mkl_emt64 library: MKL_EM64T_LIBRARY-NOTFOUND
-- guide library: GUIDE_LIBRARY-NOTFOUND
-- Found CPPUNIT header: /usr/include/cppunit/Test.h
-- Found CPPUNIT library: /usr/lib/libcppunit.so
-- using compiler: gcc version 4.4.1
-- C++ unit testing with CPPUNIT: /usr/lib/libcppunit.so
-- Adding subdirectory: unittest
-- Adding the c++ library subdirectory: common
-- Adding the cppunit subdirectory for common
-- Adding the data subdirectory for the cppunits under common
-- Adding the c++ library subdirectory: imaging
-- Adding the c++ library subdirectory: basecalling
-- Adding the cppunit subdirectory for basecalling
-- Adding the c++ library subdirectory: qcalibration
-- Adding the cppunit subdirectory for qcalibration
-- Adding the data subdirectory for the cppunits under qcalibration
-- Adding the c++ library subdirectory: statistics
-- Adding the cppunit subdirectory for statistics
-- Adding the c++ library subdirectory: alignment
-- Adding the cppunit subdirectory for alignment
-- Adding the data subdirectory for the cppunits under alignment
-- Adding the c++ library subdirectory: legacy
-- Adding the c++ program subdirectory: programs
-- Looking for doxygen...
-- Looking for doxygen... - found /usr/bin/doxygen
-- Looking for dot tool...
-- Looking for dot tool... - NOT found
-- Doxygen: /usr/bin/doxygen. Dot: DOXYGEN_DOT_EXECUTABLE-NOTFOUND.
-- Creating Doxygen config file: /share/apps/GAPipeline/build/c++/Doxyfile
-- Adding the python program subdirectory: setup
-- Adding the python program subdirectory: imaging
-- Adding the python modules subdirectory: lib
-- Adding the pyunit test subdirectory: python/pyunit/lib
-- Adding the perl program subdirectory: setup
-- Adding the perl program subdirectory: alignment
-- Adding the perl program subdirectory: statistics
-- Adding the perl program subdirectory: legacy
-- Adding the black box tests:
-- Adding the black box tests:
-- Configuring done
-- Generating done
-- Build files have been written to: /share/apps/GAPipeline/build
make --directory opt install_io_lib
make[1]: Entering directory `/share/apps/GAPipeline/opt'
make --directory io_lib
make[2]: Entering directory `/share/apps/GAPipeline/opt/io_lib'
make all-recursive
make[3]: Entering directory `/share/apps/GAPipeline/opt/io_lib'
Making all in io_lib
make[4]: Entering directory `/share/apps/GAPipeline/opt/io_lib/io_lib'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/share/apps/GAPipeline/opt/io_lib/io_lib'
Making all in progs
make[4]: Entering directory `/share/apps/GAPipeline/opt/io_lib/progs'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/share/apps/GAPipeline/opt/io_lib/progs'
Making all in tests
make[4]: Entering directory `/share/apps/GAPipeline/opt/io_lib/tests'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/share/apps/GAPipeline/opt/io_lib/tests'
make[4]: Entering directory `/share/apps/GAPipeline/opt/io_lib'
make[4]: Leaving directory `/share/apps/GAPipeline/opt/io_lib'
make[3]: Leaving directory `/share/apps/GAPipeline/opt/io_lib'
make[2]: Leaving directory `/share/apps/GAPipeline/opt/io_lib'
cp io_lib/progs/illumina2srf /share/apps/GAPipeline/bin
cp io_lib/progs/srf2illumina /share/apps/GAPipeline/bin
make[1]: Leaving directory `/share/apps/GAPipeline/opt'
make --directory build install
make[1]: Entering directory `/share/apps/GAPipeline/build'
make[2]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 0%] Built target ga_cppunit
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 11%] Built target ga_common
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 14%] Built target common_cppunitTest
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 14%] Built target common_data
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 15%] Built target common_passed
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 24%] Built target ga_imaging
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 31%] Built target ga_basecalling
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 32%] Built target basecalling_cppunitTest
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 32%] Built target basecalling_passed
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 37%] Built target ga_qcalibration
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 38%] Built target qcalibration_cppunitTest
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 38%] Built target qcalibration_data
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
[ 39%] Built target qcalibration_passed
make[3]: Entering directory `/share/apps/GAPipeline/build'
make[3]: Leaving directory `/share/apps/GAPipeline/build'
make[3]: Entering directory `/share/apps/GAPipeline/build'
[ 39%] Building CXX object c++/statistics/CMakeFiles/ga_statistics.dir/Quality_Value_Stats_Set.cpp.o
In file included from /share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:14:
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:33: error: ‘uint64_t’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:33: error: template argument 2 is invalid
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:33: error: template argument 4 is invalid
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:34: error: typedef name may not be a nested-name-specifier
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:34: error: expected ‘;’ before ‘Qual_Val_Freq_Map_CIter’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:35: error: typedef name may not be a nested-name-specifier
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:35: error: expected ‘;’ before ‘Qual_Val_Freq_Map_CRIter’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.h:39: error: ‘uint64_t’ does not name a type
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp: In constructor ‘Quality_Value_Stats_Set::Quality_Value_Stats_Set()’:
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:19: error: class ‘Quality_Value_Stats_Set’ does not have any field named ‘my_num_bases’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp: In member function ‘void Quality_Value_Stats_Set::add_read_align_info(const Read_Align_Info&)’:
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:59: error: ‘my_num_bases’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:62: error: invalid types ‘int[const int]’ for array subscript
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:65: error: invalid types ‘int[const int]’ for array subscript
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp: In function ‘std:stream& operator<<(std:stream&, const Quality_Value_Stats_Set&)’:
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:89: error: expected initializer before ‘&’ token
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:90: error: ‘uint64_t’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:90: error: expected ‘;’ before ‘cum_freq’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:91: error: expected ‘;’ before ‘cum_err_count’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:93: error: ‘Qual_Val_Freq_Map_CRIter’ is not a member of ‘Quality_Value_Stats_Set’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:94: error: expected ‘;’ before ‘pair_citer’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:95: error: ‘pair_citer’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:95: error: request for member ‘rend’ in ‘qual_val_freq_map’, which is of non-class type ‘const int’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:99: error: ‘uint64_t’ does not name a type
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:102: error: ‘Qual_Val_Freq_Map_CIter’ is not a member of ‘Quality_Value_Stats_Set’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:103: error: expected ‘;’ before ‘err_pair_citer’
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:104: error: ‘uint64_t’ does not name a type
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:109: error: ‘cum_freq’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:109: error: ‘curr_freq’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:110: error: ‘cum_err_count’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:110: error: ‘curr_err_count’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:117: error: ‘num_bases’ was not declared in this scope
/share/apps/GAPipeline/c++/statistics/Quality_Value_Stats_Set.cpp:86: warning: unused variable ‘errs_by_qual_val_freq_map’
make[3]: *** [c++/statistics/CMakeFiles/ga_statistics.dir/Quality_Value_Stats_Set.cpp.o] Error 1
make[3]: Leaving directory `/share/apps/GAPipeline/build'
make[2]: *** [c++/statistics/CMakeFiles/ga_statistics.dir/all] Error 2
make[2]: Leaving directory `/share/apps/GAPipeline/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/share/apps/GAPipeline/build'
make: *** [install] Error 2

Last edited by sanzi; 01-12-2010 at 06:43 AM.
sanzi is offline   Reply With Quote
Old 01-13-2010, 12:10 PM   #2
SillyPoint
Member
 
Location: Frederick MD, USA

Join Date: May 2008
Posts: 39
Default

Looking at my 1.5.0 install output, I see that it installed its own copy of cmake, version 2.6.2. Yours found an existing cmake, version 2.6-patch 2.

About 10 lines down in your output, cmake is executed and starts looking for the stuff it needs, like PTHREAD and ZLIB. In my output, it looks for a lot more stuff -- including stdint.h, wherein resides the declaration of uint64_t.

stdint.h is in /usr/include, just as you'd expect. It's not obvious where it gets included by the pipeline. I'm not sure how cmake gets involved in making it available -- I can't believe it would leave out /usr/include.

Nonetheless, getting the right version of cmake is where I'd start looking. I'm not sure how to get the install script to create its own version of cmake. Mine did so without being asked.

--TS
SillyPoint is offline   Reply With Quote
Old 04-03-2010, 01:45 AM   #3
cychiu98
Junior Member
 
Location: San Francisco

Join Date: Apr 2010
Posts: 2
Default Problem with GAPipeline on Ubuntu

Hi Sanzi or anyone else -- did you get this to work? I have the identical problem; reinstalling CMAKE did not help.

Thanks,
Charles
[email protected]
cychiu98 is offline   Reply With Quote
Old 04-06-2010, 04:32 AM   #4
SillyPoint
Member
 
Location: Frederick MD, USA

Join Date: May 2008
Posts: 39
Default

Hi Charles,

What version of CMAKE did you install? The problem described by Sanzi occurred with a fairly recent version.

--SP
SillyPoint is offline   Reply With Quote
Old 04-06-2010, 10:35 AM   #5
cychiu98
Junior Member
 
Location: San Francisco

Join Date: Apr 2010
Posts: 2
Default problems with installing on UBUNTU

I installed CMAKE 2.6.2. It actually turns out that my (and Sanzi's problems) are due to subtle issues with Ubuntu compatibility and the shell scripts / C programs used by the GOAT pipeline. I had to make several changes to the code "i.e. <cstdio> instead of <stdio>, const char instead of char" but the pipeline appears to be working now on Ubuntu. Thanks for your help!
cychiu98 is offline   Reply With Quote
Old 01-17-2014, 12:31 PM   #6
pci5z
Junior Member
 
Location: Boston

Join Date: Dec 2013
Posts: 1
Default

I'm currently experiencing this same problem. I need to run GAPipeline 1.5.1 on Ubuntu and am receiving the same error code (error: ‘uint64_t’ was not declared in this scope). Is there any chance you can elaborate on what changes you made to the code and where you made them? I would greatly appreciate the help.
pci5z is offline   Reply With Quote
Reply

Tags
error, gapipeline-1.5.0, install, uint64_t

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO