SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Trinity protocol] some question about step: quality assessment bongbimit Bioinformatics 4 01-24-2014 06:57 PM
Platform independent quality assessment of Exomes krawitz Bioinformatics 0 08-28-2012 03:04 AM
Mapping paired reads to de novo RNA-seq assemblies for quality assessment? BobFreemanMA Bioinformatics 1 08-02-2012 12:36 PM
Quality checking transcriptome assemblies ShellfishGene Bioinformatics 1 02-20-2010 07:44 AM
ShortRead: a bioconductor package for input, quality assessment and exploration Chien-Yuan Chen Literature Watch 0 11-09-2009 02:36 PM

Reply
 
Thread Tools
Old 02-19-2014, 02:42 PM   #1
akjones
Member
 
Location: North America

Join Date: Jun 2013
Posts: 24
Question Help installing QUAST(quality assessment tool for genome assemblies)

Hello all,

I'm having some problems with installing QUAST and I'm hoping someone out there can help. So here's the deal:

I am trying to install QUAST on my Mac (OS 10.7.5). I have xcode and all the required additions except for matplotlib. While trying to install matplotlib I run into issues because I have multiple versions of Python, the default is Python 2.7 but I also have Python 3.3. My python 2.7 does not have setuptools, which means it does not have easy_install, so my attempt at installing matplotlib (and the required numpy and nose) fails immediately. I still have not had any luck installing either setuptools or distribute for python 2.7, so that is problem #1.

Problem #2, after all this failure with Python 2.7 I decide to try and install all of the required packages in Python 3.3 (which does have setuptools and easy_install). I manage to do this successfully and think very highly of myself until I look back at the QUAST page and realize it requires Python 2. So my other question/problem is, is there a version of QUAST that will run in Python 3? I know that the syntax for Python 2.7 and Python 3 is very different, but was there ever an upgrade for QUAST that can use Python 3?

Apologies if these questions are overly simplistic, I'm still very much a beginner with programming/computing techniques.

Thanks,

~Ana
akjones is offline   Reply With Quote
Old 02-19-2014, 03:26 PM   #2
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,547
Default

Since you are stuck at the moment here are some options to try. Hopefully one of these will work.

1. http://penandpants.com/2012/02/24/install-python/

2. http://stackoverflow.com/questions/8...ipy-matplotlib

3. http://stackoverflow.com/questions/6...n-mac-osx-lion
GenoMax is offline   Reply With Quote
Old 05-27-2016, 01:51 PM   #3
lac302
Member
 
Location: DE

Join Date: Dec 2012
Posts: 57
Default

simple question for you linux users...i was running an old version of quast that was functional but warned that i needed to update the version of matplotlib i was using.

updated quast and matplotlib successfully...after installing libpng-devel

now i get this warning: WARNING: Can't draw plots: please install python-matplotlib.

i updated matplotlib from root...what is the correct location for install. does this error mean that matplotlib is not found in the python site packages.

any help would be appreciated. thanks.
lac302 is offline   Reply With Quote
Old 05-28-2016, 05:49 AM   #4
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,547
Default

Quote:
Originally Posted by lac302 View Post
simple question for you linux users...i was running an old version of quast that was functional but warned that i needed to update the version of matplotlib i was using.

updated quast and matplotlib successfully...after installing libpng-devel

now i get this warning: WARNING: Can't draw plots: please install python-matplotlib.

i updated matplotlib from root...what is the correct location for install. does this error mean that matplotlib is not found in the python site packages.

any help would be appreciated. thanks.
This is a guess but at times there may be multiple versions of python on system. Depending on which is default you may need to update/install matplotlib in that version. Take a look at the suggested install options here: http://stackoverflow.com/questions/1...tlib-in-python

Last edited by GenoMax; 05-28-2016 at 05:51 AM.
GenoMax is offline   Reply With Quote
Reply

Tags
install, numpy, python, quast, setuptools

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:47 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO