SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with cummeRbund and RSQLite noplacetoh1de Bioinformatics 9 11-03-2014 02:33 PM
Problem with cummeRbund and RSQLite :( dadada4ever Bioinformatics 3 07-31-2013 10:13 AM
CummeRbund problem in R and RSQLite vd4mindia Bioinformatics 0 05-05-2013 03:40 AM
errors during installing mira on suse 10 qingdaoalbert Bioinformatics 4 02-19-2012 06:01 PM

Reply
 
Thread Tools
Old 05-18-2013, 06:55 PM   #1
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default DBI and RSQLite Errors plus other Warnings when Installing CummeRbund

Hello RNA Seq community,

Could someone please help me? I am using the command "source('http://www.bioconductor.org/biocLite.R')
biocLite('cummeRbund')" in the R environment, and my output is:

ERROR: dependency ‘DBI’ is not available for package ‘RSQLite’
* removing ‘/home/jmwhitha/R/x86_64-pc-linux-gnu-library/2.14/RSQLite’
ERROR: dependency ‘RSQLite’ is not available for package ‘cummeRbund’
* removing ‘/home/jmwhitha/R/x86_64-pc-linux-gnu-library/2.14/cummeRbund’

The downloaded packages are in
‘/tmp/Rtmp8pQWJT/downloaded_packages’
Warning messages:
1: In install.packages(pkgs = pkgs, repos = repos, ...) :
installation of package ‘RSQLite’ had non-zero exit status
2: In install.packages(pkgs = pkgs, repos = repos, ...) :
installation of package ‘cummeRbund’ had non-zero exit status
3: 'cluster' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'foreign' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'KernSmooth' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'mgcv' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'nnet' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'rpart' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'survival' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
jmwhitha is offline   Reply With Quote
Old 05-20-2013, 06:21 AM   #2
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Hello RNA Seq community,

Sorry, I think I posted this at a time when no would answer it.

Could someone please help me? I am using the command "source('http://www.bioconductor.org/biocLite.R')
biocLite('cummeRbund')" in the R environment, and my output is:

ERROR: dependency ‘DBI’ is not available for package ‘RSQLite’
* removing ‘/home/jmwhitha/R/x86_64-pc-linux-gnu-library/2.14/RSQLite’
ERROR: dependency ‘RSQLite’ is not available for package ‘cummeRbund’
* removing ‘/home/jmwhitha/R/x86_64-pc-linux-gnu-library/2.14/cummeRbund’

The downloaded packages are in
‘/tmp/Rtmp8pQWJT/downloaded_packages’
Warning messages:
1: In install.packages(pkgs = pkgs, repos = repos, ...) :
installation of package ‘RSQLite’ had non-zero exit status
2: In install.packages(pkgs = pkgs, repos = repos, ...) :
installation of package ‘cummeRbund’ had non-zero exit status
3: 'cluster' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'foreign' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'KernSmooth' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'mgcv' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'nnet' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'rpart' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
'survival' cannot be updated, installed directory '/usr/lib/R/library' not
writeable
jmwhitha is offline   Reply With Quote
Old 05-20-2013, 06:33 AM   #3
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,550
Default

You need to install the following packages at a minimum:

http://cran.r-project.org/web/packages/DBI/index.html
http://cran.r-project.org/web/packag...ite/index.html

Check the dependancy section for cummerbund package for anything else you may need: http://www.bioconductor.org/packages...ummeRbund.html

There also appears to be an issue where /usr/lib/R/library is not writable from the account you are trying to install the packages from.

I remember you being the "sys admin" for this system from past posts. Try doing the cummerbund install as a user with write privileges to that directory path.

Last edited by GenoMax; 05-20-2013 at 06:36 AM.
GenoMax is offline   Reply With Quote
Old 05-20-2013, 06:52 AM   #4
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Good morning GenoMax,

Thank you for the quick reply!

Before posting this topic, I used the following commands to get DBI and RSQLite.
wget http://cran.fhcrc.org/src/contrib/DBI_0.2-7.tar.gz -O DBI_0.2-7.tar.gz
tar zxvf DBI_0.2-7.tar.gz
wget http://cran.r-project.org/src/contri..._0.11.3.tar.gz -O RSQLite_0.11.3.tar.gz
tar zxvf RSQLite_0.11.3.tar.gz

I guess that's not enough code to get the job done though. I also just noticed that DBI requires R version >= 2.15.0

The following command only gets me version 2.14.1 though.
sudo apt-get install r-base-core

What commands can I use to get >= 2.15.0?


Concerning the following, would I use the command?
sudo chmod 777 /usr/lib/R/library

Could you break the second sentence down for me a little more. I'm not really sure what installing as a user with write privileges to that directory path entails.

Quote:
Originally Posted by GenoMax View Post
You need to install the following packages at a minimum:

There also appears to be an issue where /usr/lib/R/library is not writable from the account you are trying to install the packages from.

I remember you being the "sys admin" for this system from past posts. Try doing the cummerbund install as a user with write privileges to that directory path.
Thank you so much!
Jason
jmwhitha is offline   Reply With Quote
Old 05-20-2013, 07:20 AM   #5
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,550
Default

Jason,

Just downloading the packages in not enough to install them. Here is a reference for installing packages in R. It is possible to install R libraries under your own user directory (so you do not need to write in /usr area, which is system reserved).

Since you are the only user on your system it may be worth trying the install cummerBund by starting R as root. This should give you write permissions to the /usr/lib/R/library directory.

Code:
sudo R
Then in R do the "cummerBund" install.
Code:
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")
If that works then remember to close R and then start R back as a regular user.
GenoMax is offline   Reply With Quote
Old 05-20-2013, 08:59 AM   #6
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Thanks for the document.

Most of the installation seems to work, except DBI still needs a newer version of R.

I tried to use the document to get 2.15.0 using the following code:

wget http://cran.stat.ucla.edu/src/base/R-2/R-2.15.0.tar.gz -O R-2.15.0.tar.gz
tar xf R-2.15.0.tar.gz
#Before executing ./configure you need to get X11 headers
#http://forum.linuxcareer.com/threads...-not-available
sudo apt-get install xorg-dev
./configure
make

Again, this seemed to work great, except when I execute "R", it's still using 2.14.1. How do I get it to launch the 2.15.0 version?

Thank you again!
jmwhitha is offline   Reply With Quote
Old 05-20-2013, 09:45 AM   #7
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Oh, I figured that out.

I just went into ~/bin/R-2.15.0/bin and executed ./R

Installation of cummeRbund worked in this version!
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")

Unfortunately, executing just "R" gives me the old version.

Can I do something to make it so that when I execute "R" without setting a path, it gives me the new version?

Thank you!
jmwhitha is offline   Reply With Quote
Old 05-20-2013, 10:34 AM   #8
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,550
Default

Quote:
Originally Posted by jmwhitha View Post
Oh, I figured that out.

I just went into ~/bin/R-2.15.0/bin and executed ./R

Installation of cummeRbund worked in this version!
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")

Unfortunately, executing just "R" gives me the old version.

Can I do something to make it so that when I execute "R" without setting a path, it gives me the new version?

Thank you!
Open a new terminal window. Check to see where is the default "R" that you are getting is located.

Code:
which R
Then do a

Code:
ls -l full_path_to_location_from_above_command
Depending on what the answer is we can decide on an appropriate method.
GenoMax is offline   Reply With Quote
Old 05-20-2013, 10:38 AM   #9
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Thanks GenoMax,

Just was emailing with another friend and he helped me get these two commands...

sudo rm -f ./R #after cd'ing to the directory containing the old version /usr/bin
sudo ln -s /path/to/new/R R #where R is an executable, not a directory

...and they worked great!!

PROBLEM SOLVED

God bless,
Jason
jmwhitha is offline   Reply With Quote
Old 06-05-2013, 04:20 PM   #10
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default still errors

Hey, guys

I was following your discussion, but still have error messages, could you share some thoughts on this, thanks a lot!
:

wget http://cran.stat.ucla.edu/src/base/R-2/R-2.15.0.tar.gz -O R-2.15.0.tar.gz

tar xf R-2.15.0.tar.gz

sudo apt-get install xorg-dev

./configure

make

~/bin/R-2.15.0/bin

./R

source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")

However, still have the following errors:
The downloaded source packages are in
‘/tmp/Rtmpk15EqK/downloaded_packages’
Updating HTML index of packages in '.Library'
Making packages.html ... done
Warning messages:
1: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘XML’ had non-zero exit status
2: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘RCurl’ had non-zero exit status
3: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘biomaRt’ had non-zero exit status
4: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘rtracklayer’ had non-zero exit status
5: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘GenomicFeatures’ had non-zero exit status
6: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘biovizBase’ had non-zero exit status
7: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘Gviz’ had non-zero exit status
8: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘cummeRbund’ had non-zero exit status
Baoqing is offline   Reply With Quote
Old 06-05-2013, 04:41 PM   #11
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,550
Default

It appears that you are missing some libraries:

If this is ubuntu then

Code:
sudo apt-get install libxml2-dev libxml2 curl curl-devel
You may also need to install some R-packages. Check the "depends" section from the cummerBund package page: http://www.bioconductor.org/packages...ummeRbund.html
GenoMax is offline   Reply With Quote
Old 06-05-2013, 05:20 PM   #12
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default

ok, problem solved now.

I used one of the code you gave to other threads

sudo apt-get install libcurl4-openssl-dev

after installation, then reinstall it, now the biocLite("cummeRbund")
is loaded.

Thanks!
Baoqing is offline   Reply With Quote
Old 06-05-2013, 05:37 PM   #13
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default compiled info to install cummeRbund in ubuntu

wget http://cran.stat.ucla.edu/src/base/R-2/R-2.15.0.tar.gz -O R-2.15.0.tar.gz

tar xf R-2.15.0.tar.gz

sudo apt-get install xorg-dev

./configure

make

~/bin/R-2.15.0/bin

./R
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")
# if the installation is not success, quit R and go back to ubuntu console
q()

sudo apt-get install libcurl4-openssl-dev

R

#Reinstall it
source("http://bioconductor.org/biocLite.R")
biocLite("cummeRbund")

#then load the library, to see if all of the dependent packages are there
library(cummeRbund)

#change the directory of R
sudo rm -f ./R #after cd'ing to the directory containing the old version /usr/bin
sudo ln -s /path/to/new/R R #where R is an executable, not a directory
Baoqing is offline   Reply With Quote
Old 06-10-2013, 06:47 AM   #14
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Sorry I didn't get to this sooner. I just got back from Thailand.
jmwhitha is offline   Reply With Quote
Old 06-10-2013, 07:18 AM   #15
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default

Thats cool.

But I do have the following up question though. After load the library(CummeRbund). All of the dependents were loaded simultaneously. I would assume that the package is install properly. However, when i was trying to run the analysis.

> cuff_data = readCufflinks('diff_out')
> cuff_data
CuffSet instance with:
2 samples
5902 genes
0 isoforms
0 TSS
0 CDS
0 promoters
0 splicing
0 relCDS
> csScatter(genes(cuff_data), '024', '025')
Error in .local(object, x, y, logMode, pseudocount, labels, smooth, ...) :
One or more values of 'x' or 'y' are not valid sample names!
Both instances are strange to me, because when I open the expression files. Those files are not empty(not necessarily mean not possible to have no isoforms or something else, how can i visually check the isoforms in the data sheet or TSS, etc, is there any thing specific labels with those?

Further more, when i was looking at the different expressed gene.
> gene_diff_data = diffData(genes(cuff_data))
> sig_gene_data = subset(gene_diff_data, (significant =='yes'))
> nrow(sig_gene_data)
[1] 0
This is certainly not the case, clearly in the result datasheet, dozens of genes have been listed as significant difference.

Best,

Last edited by Baoqing; 06-10-2013 at 07:36 AM.
Baoqing is offline   Reply With Quote
Old 06-10-2013, 08:27 AM   #16
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Sorry again Baoqing, I cannot answer this one. I am still working on getting the example from the publication to work, and I am trying to back everything up right now before I finish that.
jmwhitha is offline   Reply With Quote
Old 06-10-2013, 09:34 AM   #17
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default

Thanks a lot!

I will also keep working on mine and keep this post updated periodically.
Baoqing is offline   Reply With Quote
Old 06-12-2013, 12:14 PM   #18
Baoqing
Member
 
Location: Texas

Join Date: Jan 2013
Posts: 24
Default

Ok, problem solved.

Two things need to be considered
1 when name your samples "alphabet+ numbers" always help!
2 In case of error, you need to delete cuffData.db in the folder before re-run it.
Baoqing is offline   Reply With Quote
Old 06-22-2013, 09:14 AM   #19
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

What do you mean Baoqing when you say, "2. In case of error, you need to delete cuffData.db in the folder before re-run it."?

I didn't do #1 at first and had problems. So I re-ran the cuffdiff command with alphabet+numbers, and got the error message, "Error in .local(object, x, y, logMode, pseudocount, labels, smooth, ...) :"

What command do I use to "delete the cuffData.db"?

Thank you!
jmwhitha is offline   Reply With Quote
Old 06-22-2013, 09:32 AM   #20
jmwhitha
Senior Member
 
Location: NC State, Raleigh, NC

Join Date: Mar 2013
Posts: 105
Default

Are you saying, delete cuffData.db in linux or R?
jmwhitha is offline   Reply With Quote
Reply

Tags
cummerbund, dbi, dependency, install, rsqlite

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 07:48 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO