SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
tophat Error running running 'prep_reads' victoryhe Bioinformatics 2 10-17-2011 04:53 AM
problem running TopHat anecsulea Bioinformatics 1 03-28-2011 03:47 AM
problem running TopHat anecsulea RNA Sequencing 0 05-28-2010 12:44 AM
a tophat running problem clariet Bioinformatics 1 04-12-2010 05:05 AM
tophat running problem yasu Bioinformatics 4 02-08-2010 10:54 PM

Reply
 
Thread Tools
Old 06-17-2016, 05:55 AM   #1
luana
Member
 
Location: Brazil

Join Date: May 2016
Posts: 14
Angry Problem with running tophat

I tried to run tophat a lot and I haven't success. I need help please!!!!!
My reads were sequencing at Solid and this version support this kind of read with the bowtie 1 ( I used Bowtie 1.1.1). I indexed the Phaseolus' genome (.ebtw).

$ tophat --color --quals -r -p fr-secondstrand ebwt_base_index.fa -o NGR1_NGR2_1_thout genome NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR1.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR2.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR1.qual NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR2.qual

Traceback (most recent call last):
File "/usr/bin/tophat", line 4107, in <module>
sys.exit(main())
File "/usr/bin/tophat", line 3858, in main
args = params.parse_options(argv)
File "/usr/bin/tophat", line 1008, in parse_options
self.read_params.parse_options(opts)
File "/usr/bin/tophat", line 467, in parse_options
self.mate_inner_dist = int(value)
ValueError: invalid literal for int() with base 10: '-p'

Anyone could help me to solved this?????
luana is offline   Reply With Quote
Old 06-17-2016, 10:01 AM   #2
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

If you use the parameter -r, then you need to specify an integer value for -r, the mate inner distance (distance between the two reads of a pair).

Otherwise, if you don't specify -r, the tophat manual says the default value is 50.
mastal is offline   Reply With Quote
Old 06-17-2016, 10:38 AM   #3
luana
Member
 
Location: Brazil

Join Date: May 2016
Posts: 14
Default

Now I don't specify the -r and this message appeared..the files indexes are at directory

tophat --color --quals fr-secondstran genome.fa -o NGR1_NGR2_1_thout genome NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR1.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR2.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR1.qual NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR2.qual

[2016-06-17 15:24:41] Beginning TopHat run (v2.1.0)
-----------------------------------------------
[2016-06-17 15:24:41] Checking for Bowtie
Bowtie version: 1.1.1.0
[2016-06-17 15:24:41] Checking for Bowtie index files (genome)..
Error: Could not find Bowtie index files (fr-secondstran.*.ebwt)

What's the problem?
luana is offline   Reply With Quote
Old 06-17-2016, 10:49 AM   #4
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,062
Default

You have not specified the "basename" (ebwt_base_index, if that is the name) of the index files for the genome that you are searching against.
GenoMax is offline   Reply With Quote
Old 06-17-2016, 10:53 AM   #5
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

Hi Luana,

You are missing the final 'd' from fr-secondstrand, and you are also
missing the /path/to/ the bowtie index (give only the prefix of the index name).

Last edited by mastal; 06-17-2016 at 11:04 AM.
mastal is offline   Reply With Quote
Old 06-22-2016, 05:39 AM   #6
luana
Member
 
Location: Brazil

Join Date: May 2016
Posts: 14
Default

Hi Guys,
I'm trying to fix this script but the problem persist. I put the "d" in the fr-secondstrand, but I didn't understand witch file from index directory I have to use.
When I indexed the genome I used the fasta file and I had six files .ebwt
How file index .ebwt I have to use in this script?

tophat --color --quals fr-secondstrand /bowtie/bowtie-index/ebwt_base -o NGR1_NGR2_1_thout genome NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR1.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_NGR2.csfasta NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR1.qual NFN_run6_Transcriptoma_29102013_bcSample1_F3_QV_NGR2.qual

[2016-06-22 10:12:38] Beginning TopHat run (v2.1.0)
-----------------------------------------------
[2016-06-22 10:12:38] Checking for Bowtie
Bowtie version: 1.1.1.0
[2016-06-22 10:12:38] Checking for Bowtie index files (genome)..
Error: Could not find Bowtie index files (fr-secondstrand.*.ebwt)
luana is offline   Reply With Quote
Old 06-22-2016, 06:12 AM   #7
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

you use what is know as the 'prefix', the common part of the filename before the .ebwt, so all 6 of your index files should have the same 'prefix'.

Also, do you have single-end or paired-end reads? If your reads are single-end, then you should have a comma instead of a space between the names of the two read files, and between the names of the 2 quality files.

Last edited by mastal; 06-22-2016 at 06:24 AM.
mastal is offline   Reply With Quote
Reply

Tags
tophat 2.1.0

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:38 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO