SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finding splice sites: TopHat and SOAPsplice export empty junction files jgw RNA Sequencing 0 01-31-2012 12:04 PM
Trouble getting TopHat to work -- empty junctions.bed thurisaz RNA Sequencing 6 12-01-2011 12:13 PM
Empty junction.bed TopHat vinay052003 Bioinformatics 0 11-24-2011 05:53 PM
Tophat and SOLID -> zero kb .bed files ahmetz Bioinformatics 1 06-16-2011 02:04 PM
Tophat: some .sam files empty and some not oliviera RNA Sequencing 0 07-13-2010 04:35 AM

Reply
 
Thread Tools
Old 11-27-2010, 06:42 AM   #1
lianzinho
Junior Member
 
Location: Brazil

Join Date: Mar 2010
Posts: 1
Default TopHat v1.1.4 - Empty *.bed files

Hello folks, Im trying to run tophat on some 27bp single end illumina reads with a reference GTF for searching splice junctions.

My mapping reference is just the chr14 and so is the GTF that I retrieved from UCSC genome browser.

The problem is that in despite of not showing any errors in the log files, my *.bed output with the junctions is always empty!! So Im in doubt if there is something wrong of if there really wasnt any output what I find a little odd bacause of the long time it took to try to align the reads with the junctions. Take a look at the log file of the output:

Code:
[Fri Nov 26 08:19:34 2010] Beginning TopHat run (v1.1.4)
-----------------------------------------------
[Fri Nov 26 08:19:34 2010] Preparing output location /usr/local/tophat//
[Fri Nov 26 08:19:34 2010] Checking for Bowtie index files
[Fri Nov 26 08:19:34 2010] Checking for reference FASTA file
[Fri Nov 26 08:19:34 2010] Checking for Bowtie
       Bowtie version:                  0.12.7.0
[Fri Nov 26 08:19:34 2010] Checking for Samtools
       Samtools version:                0.1.11.0
[Fri Nov 26 08:19:34 2010] Checking reads
       min read length: 27bp, max read length: 27bp
       format:          fastq
       quality scale:   phred33 (default)
[Fri Nov 26 08:21:25 2010] Reading known junctions from GTF file
[Fri Nov 26 08:21:49 2010] Mapping reads against chr14.ucsc with Bowtie
[Fri Nov 26 08:26:23 2010] Joining segment hits
[Fri Nov 26 08:29:13 2010] Mapping reads against chr14.ucsc with Bowtie(1/3)
[Fri Nov 26 08:34:02 2010] Mapping reads against chr14.ucsc with Bowtie(2/3)
[Fri Nov 26 08:38:43 2010] Mapping reads against chr14.ucsc with Bowtie(3/3)
[Fri Nov 26 08:43:27 2010] Searching for junctions via segment mapping
[Fri Nov 26 08:43:31 2010] Retrieving sequences for splices
[Fri Nov 26 08:43:35 2010] Indexing splices
[Fri Nov 26 08:43:35 2010] Mapping reads against segment_juncs with Bowtie
[Fri Nov 26 09:59:20 2010] Mapping reads against segment_juncs with Bowtie
[Fri Nov 26 11:11:12 2010] Mapping reads against segment_juncs with Bowtie
[Fri Nov 26 12:25:22 2010] Joining segment hits
[Fri Nov 26 12:31:28 2010] Reporting output tracks
-----------------------------------------------
Run complete [04:12:35 elapsed]
Aparently its ok, but if I look to the junctions.bed its shows only the title:

Code:
track name=junctions description="TopHat junctions"

Please help, tophat parameters are default, i just changed the -p option to use all the cpus of my machine.

Thanks,
Halian

Last edited by lianzinho; 11-27-2010 at 06:47 AM.
lianzinho is offline   Reply With Quote
Old 12-08-2010, 09:36 AM   #2
wdt
Member
 
Location: Southwest

Join Date: Oct 2009
Posts: 19
Default

Hello there,

I am having a similar issue with empty junctions.bed file and was wondering
if you were able to resolve it successfully. Could you
share the solution?

Thanks,
wdt is offline   Reply With Quote
Old 06-24-2011, 09:39 AM   #3
CompBio
Member
 
Location: Bristol, UK

Join Date: Aug 2009
Posts: 26
Default

Were either of you able to solve your problems? I'm running into the same thing with TopHat 1.3.0 -- all the .bed files are empty, save for the file headers. Currently I'm running using default options with the following exceptions:

-a 10
-g 1
-F 0

In desperation I may drop the anchor size to something silly, like 4, or raise mismatches to 2 or 3. But I was able to align the same data with an old version of TopHat with these same parameters.
CompBio is offline   Reply With Quote
Old 06-27-2011, 09:44 AM   #4
jjpurwar
Junior Member
 
Location: Salt Lake City

Join Date: Jun 2011
Posts: 9
Default

Im having the same issue. Interestingly, when my input file has reads that are 50 bp, my *.bed files are NOT empty. However, when using a 36 bp input file, the *.bed files are empty.
Any clues on how to fix this?
jjpurwar is offline   Reply With Quote
Old 06-27-2011, 06:48 PM   #5
jjpurwar
Junior Member
 
Location: Salt Lake City

Join Date: Jun 2011
Posts: 9
Default

Figured a fix for this - the segment-length needs to be set to atleast half of the read length. else junctions wont be reported.
jjpurwar is offline   Reply With Quote
Old 06-30-2011, 01:55 AM   #6
thurisaz
Member
 
Location: Finland

Join Date: Jun 2011
Posts: 24
Default

jjpurwar, do you mean to say that segment-length should be at most half the read length (or, alternately, that the read length should be at least 2 * segment-length)? That would seem to make more sense given the description for --segment-length in the manual:

"Each read is cut up into segments, each at least this long. These segments are mapped independently. The default is 25."

As I understand it, if segment-length > 0.5 * read-length, then only one segment will be made for each read (and the remainder discarded?), which is why it's having trouble finding junctions.

I got an empty junctions.bed (and a "junction database is empty!" message) when trying out TopHat with the default settings on some published RNASeq data with 35-bp SOLiD reads; I'm about to try a new run with segment-length set to 17 to see if that works.
thurisaz is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO